1

I'm using cwrsync on windows. This is my daemon config file

use chroot = false
strict modes = false
hosts allow = *
log file = rsyncd.log
pid file = rsyncd.pid
port = 11011

# Module definitions
# Remember cygwin naming conventions : c:\work becomes /cygdrive/c/work
#

[read]
path = /cygdrive/o/MBackupData/out/
read only = true
transfer logging = yes
list = true
timeout = 30

[write]
path = /cygdrive/o/MBackupData/in/
read only = false
write only = false
transfer logging = yes
list = true
timeout = 30
refuse options = delete

The modules all point to a ntfs partition. I'm using this command to write files to it:

bin\rsync -v --append --perms --remove-source-files --partial --modify-window=1 -z --compress-level=9 --progress --times --stats --links --port=11011 /cygdrive/o/MBackupData/out/*.* 192.168.1.5::write/

It works, but for some reason, all the files have the read-only flag set. The source files don't have that flag. How can I configure it to not set that flag?

2

I'm not sure why this is needed, but it works for me. I'ld classify this as a workaround though.

Adding

--chmod=a=rw,Da+x

to the clients parameters list removes the read-only flag on the server side.

2

Make sure that you setup cwRsync for not to process permissions at client side, and remove --perms from your command line. It has no meaning for windows-based operations.

If you want to transfer permission or alike, you may consider to take an additional step described here.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.