Here's the Situation

I have a Mac Pro, and it runs Mac OSX 10.7.4. For faster performance and startup speed, and an easier way for me to backup my files, I did the following 3 modifications:

1) I moved the Home folder to a separate HDD.

2) I "moved" the Applications folder to an SSD drive using symlinks.

3) I installed the OS on its own SSD drive.

I have been able to run everything quite smoothly, have had almost no problems installing any applications, have had no issues accessing anything I needed.

The only times I've noticed hiccups is when an install application refuses to follow the symlink for some reason, and installs on the original Home's Application folder (when this happens, I just drag the app file over to my Applications SSD).

The Battle

I'm trying to install software for a Razer Naga 2014 mouse. This means it's either Razer Synapse 2 or Steermouse.

Razer Synapse 2: http://www.razerzone.com/synapse2

Steermouse: http://plentycom.jp/en/steermouse/index.html

This software is meant to allow me to remap the buttons on my mouse (it has 19 buttons).

The Problem

For either of these programs, I've been going through the same process:

1) Downloaded the software from their websites, respectively

2) Ran the dmg, ran the pkg install

3) Installation requires me to restart, so I restart

4) After restart, the app files still do not exist in ANY of my Applications folders

I am thinking the three modifications I did to my Mac Pro are the cause of this. That the install apps are getting confused in the remapping. Both apps only allow me to install on the Volume where my OS is installed (I cannot, for instance, select the Applications SSD to install it - MUST be the OS boot drive).

One Nasty Solution?

I've thought about this and I'm worried the only way I MAY be able to get past this is to break the Applications folder symlink, run the install again, hope it installs properly, then re-apply the symlink.
By doing it that way, perhaps the app will install in the OS boot drive (as it seems to want to do), even if it's not on my Applications SSD?

I'm out of ideas :(.


I'v had the same problem. Fixed it by creating a new user account back on the volume where the OS is. Not sure if the problem got solved because I created a new user folder (mb permissions got screwed up when I initially cloned my user folder to another volume) or because of an issue Synapse has with the home folder being on another volume.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.