0

I know this sounds a lot like this but I just confirmed that my MBR is fine as well as the SSD drive in question.

What happened: I upgraded my be-quiet 700w PSU to the 1000w dark power pro. When I tried booting the system and none of the drives (all SATA) were detected, resulting in the "Boot device failure" error. After that I unplugged all but the boot drive, triple checked that all cables were in fact nice and tight inside their sockets, replaced both e-SATA and power cables ; still with the same outcome. Finally I reconnected my old PSU and sure enough the PC booted without any hassle (except of course for the direful construction that is currently occupying my desk).

Does anybody have any advice on how to proceed? Surely, it is possible the PSU is faulty but are there other explanations?

Thanks in advance

PS. if of any help: Motherboard is GIGABYTE GA-PH67A-UD3-B3 H67 LGA 1155

7
  • Have you tried putting the drives on a different power rail? The rail you might be using from the PSU could be faulty. Oct 22 '13 at 20:32
  • Yes I did that, no luck there, either. Oct 22 '13 at 20:36
  • What other devices if your PSU connected to? MB, HD, Video?, CDROM? When you go into the BIOS, does it show them?
    – Jason McD
    Oct 22 '13 at 20:39
  • I would suspect the drives aren't getting power for some reason. Oct 22 '13 at 20:49
  • @DavidSchwartz I guess your right. I just tried connecting an HDD, it didn't even seem to spin up. @ Jason MB (24 pin, 2x P4), boot drive (SSD) and video. Oct 22 '13 at 20:54
0

Believe it or not I have had brand new power supply units that had an issue right out of the box. The best method at this point for double checking the PSU is to get a hold of a PSU testing unit. I have done several refurbs and repairs for buds & acquaintances as well as built or upgraded all of my own units for years.......... A decent little PSU tester is a must.

Your problem sounds a lot like there is simply no power or insufficient power being delivered to the SATA drives. Also double check the actual SATA cables, be sure they are properly seated on the MB & the drive. A PSU tester can be had for 10 -25 $$ but usually these days you have to order one, call on any friends or such you know who might have one available for you to borrow. Good luck.

mark

1
  • Can't believe this took 6 month. I got my money back quite a while ago but it wasn't until today that I was notified, the PSU was actually faulty. Apr 24 '14 at 20:49
0

Have you tried resetting your BIOS by pulling the battery out and then check your BIOS for drive settings? It could be that the drives are on a wrong config after switching the PSU.

3
  • 1
    Not really likely... CMOS memory is protected by a checksum, so anything (voltage spike, etc.) that changed, i.e., corrupted the memory would have triggered an alert. Also, putting back the original PSU wouldn't have worked.
    – LSerni
    Oct 22 '13 at 21:37
  • @Scout. I think it is a good thing to ask if the BIOS/UEFO settings are still correct, however 1) I do not think it is a full answer. It would be better as a comment. 2) Lserni is correct about the checksums.
    – Hennes
    Oct 22 '13 at 21:41
  • @Iserni forgot about the checksum. You are right on that one. Hennes, I am still trying to find out how to make a commment, can't find it yet ;) But will try to do my best. But my question still stands about the BIOS settings
    – Scott
    Oct 23 '13 at 9:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.