10

I was using Rufus (on Windows 8) to create a bootable Windows 7 USB installer but midway through I canceled it. Now my USB drive is not detected by Windows or Rufus.

Is it possible to fix this?

Edit: The USB drive shows up in Device Manager.

3
  • 3
    What do you see in Disk Management?
    – ernie
    Oct 22, 2013 at 23:09
  • 3
    rufus, winformat, rmprepusb, OR any software CANNOT DAMAGE USB DRIVES, but what they can do is to force your usb drive to the limit (rufus in particular do that when you let it test for bad blocks), and if your hardware is poor ... guess what (usually cheap = poor), the only way I ever break an usb drive was when I insert it in front of an computer with internal usb cables connected wrong (and I guess 5V went on a data pin) ... as a recovery try to use another computer/usb port, I had surpises like using rufus on a flash card works on external usb card reader but don't on internal one (laptop) Feb 5, 2015 at 13:20
  • For me help only: hddguru.com/software/HDD-LLF-Low-Level-Format-Tool where I can remove MBR and after in MIni Tool partition wizard I could again format flash drive and recreate partition.
    – mtrakal
    Sep 22, 2017 at 23:43

7 Answers 7

37

As the author of Rufus, I can tell you exactly what happened.

First of all, Rufus didn't damage your USB drive. It only removed the letter Windows assigned it, which it needs to do to be able to repartition and format it, and since you cancelled that operation, the drive letter was not assigned back. This is why you couldn't see it in Explorer, but you could still see it in Device Manager/Disk Manager.

The simple option, to make your drive listed again so that you could format it and get a letter reassigned, was to follow this entry from the Rufus FAQ. A couple of clicks in Rufus was all that was needed.

Also, the latest versions of Rufus has improved the default enumeration process and will automatically list raw or unpartitioned drives, so you should no longer have to do anything even if you cancel in the middle of a bad blocks check or a format operation.

1
  • 1
    Rufus is the best software ..I had a corrupt HDD and card ...no formatter in worked worked .. Then RUFU to rescue , it formatted them with ease...till this day whenever i need to format them i used Rufus ,Thanks for developing Rufus.. its saved me A lot Jun 25, 2021 at 20:32
9

I was able to fix the damaged USB by doing the following:

  1. Go in Start > write “cmd” > right-click the Windows Command Prompt and choose to run it as an Administrator.
  2. At the prompt, enter “DISKPART” to launch Microsoft’s disk management utility. It will take a second until it loads and when ready it will read “DISKPART>”.
  3. Type in “list disk” to show a list of all disk drives. If your USB key is plugged into your PC, it should be listed here, along with other drives. Note the USB key’s disk number – you can pick it out by looking at the disk capacity.
  4. Type “select disk n" (whatever is your USB disk number in place of "n").
  5. Type “clean” for the utility to clean the disk, which DiskPart will confirm.
  6. Create a new partition by entering “create partition primary”.
  7. Choose this partition with “select partition 1", and then mark it as active by typing “active”.
  8. Format the key by inputting “format fs=fat32". This should take a few minutes, and DiskPart will display a progress percentage.
  9. Lastly, type “assign” to give this USB key a drive letter and “exit” to exit DiskPart.

From here: http://www.sevenforums.com/hardware-devices/218512-usb-flash-drive-not-recognized.html#post1831343

3
  • Proof: Last 2 mins of youtube.com/watch?v=XoINdNWVgYo Apr 27, 2014 at 17:27
  • u can use format fs=fat32 quick for quick format. also fs=ntfs is valid.
    – cyptus
    Dec 19, 2019 at 10:19
  • at the first run after a fresh created rufus-stick clean always runs me into a bluescreen. second run works fine.
    – cyptus
    Dec 19, 2019 at 10:20
5

I did "DD" writing of linux ISO image in Rufus. It went well, linux boots from that USB stick. But windows does not show my usb disk anymore as drive.

But by Rufus it can be seen as "NO_LABEL (Disk 2) [16GB]". I just selected "boot section" dropdown menu to "not bootable", clicked "start" in Rufus. And voila my USB stick is now again recognized in windows :)

See screenshot.

enter image description here

0

The simple fix for this is to repartition your USB drive using Partition Wizard software. This will be the easy method for people who are not at all experts in command line.

Download Partition Wizard from here

  • After Plugging in the USB, Open the Partition wizard software.
  • Spot your USB Drive in the list.
  • Just right click and delete the existing parttiion. Again rightclick and create new. Click Apply.

Thats it. Your USB drive is back to work without any confusions.

let me know if u got struct somewhere.

0

I fixed the issue along the lines suggested by pbatard (but he did not detail what to do).

  1. Open Disk Management. In the command prompt, type diskmgmt.msc. You may have to hit Ctrl+Enter to get Admin access. Or see this.

  2. You will probably see the USB flash. Right click on it, select Change Drive Letter and Paths.

  3. You will probably see that it has no assigned letter. Assign one.

This brought back my flash drive, in its original state (with all files present prior to running Rufus). That is it.

0

I was faced with a similar issue.

I'd connected my flash memory to a USB 3.1 port and Windows 10 could not recognize it with the new format.

I just put it into a USB 3 port and it worked.

1
  • This is also could be possible. I'm wondering why it got downvoted! Someone may read this, try and solve his/her problem. Nov 1, 2018 at 13:08
0

Another possibility is the device used to connect the USB drive to the PC doesn't fully support the drive - it can use it, but not format it properly. You may not be aware of this without checking the device's specs. In this case the USB drive can be reformatted using a device that does fully support it, and then Rufus will work through that device.

Specific example: I tried to use a 256Gb SD card in a GoPro Connect2 camera, which only fully supports 64Gb cards. Rufus (v3.14 in Windows 10) couldn't complete writing an image to it, and when I tried again with option "Check device for bad blocks" it seemed to get stuck in a loop (I left it on 64%, next morning it was back on 23%); when I cancelled the check the card was left unusable, similar to what OP saw - and was invisible even in Disk Manager on Windows 10. I used a newer camera to reformat it and then tried Rufus again and it worked fine.

NB: I know in edited version of question OP says they could see it in Disk Manager - so this is not the same scenario - but it still matches the question title, which led me here in the first place.

Not the answer you're looking for? Browse other questions tagged or ask your own question.