4

I'll like to use vim terminal in ConEmu with Solarized color scheme. After configuring ConEmu and vimrc, some of the text from the help file is unreadable as shown below.

vim screenshot My vimrc:

runtime bundle/vim-pathogen/autoload/pathogen.vim

execute pathogen#infect()
syntax on
filetype plugin indent on

let g:solarized_termtrans = 1
set background=dark
colorscheme solarized

set tabstop=4 shiftwidth=4 softtabstop=4 noexpandtab

My ConEmu settings:

ConEmu settings

  • 1
    I believe, smth is wrong with your vim config. It draw text with both background and foreground with #4 color. You may show real console (Ctrl+Win+Alt+Space) to ensure that text is unreadable there too. – Maximus Oct 26 '13 at 1:33
  • You are right. I have updated the answer accordingly. – xamfoo Oct 28 '13 at 6:13
2

Found that this is a vim/solarized/cmd related problem. Instead of changing the ConEmu color settings, I can resolve this by adding this to my vimrc:

let g:solarized_underline=0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.