2

Trying to install openssl-devel on RHEL 6.2.

yum install openssl-devel

And i am getting this error:

--> Finished Dependency Resolution
Error: Package: glibc-2.12-1.47.el6.i686 (rhel62)
       Requires: glibc-common = 2.12-1.47.el6
       Removing: glibc-common-2.12-1.47.el6.x86_64 (@anaconda-RedHatEnterpriseLinux-201111171049.x86_64/6.2)
           glibc-common = 2.12-1.47.el6
       Updated By: glibc-common-2.12-1.80.el6_3.7.x86_64 (rhel62-update)
           glibc-common = 2.12-1.80.el6_3.7
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

--skip-broken does not help. How can I fix this?


Update: Fixed by updating ro RHEL 6.4

  • 1
    Are you mixing 32bit and 64bit? What error do you get if you try to uninstall glibc-common-2.12-1.47.el6.x86_64 manually? – Rik Oct 23 '13 at 12:00
  • We don't have enough of your output of yum. What package does it say is going to be installed. The .x86_64 or the i686 version ? I think there is some mixing of 32bit and 64bit going on here. Please give the complete output of yum install openssl-devel. – Rik Oct 25 '13 at 8:05
2

Have you tried making sure you have up to date information in your RPM databases? Something along the lines yum clean all && yum update might be in order at this point.

  • Got the same error on yum update – Timur Oct 25 '13 at 4:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.