On my 2012 MacBook Pro (15 inch, non retina, i7, 10GB RAM) after successful installation when Mavericks tried to boot, it is freezing there with "Still waiting for root device" (Seen Using CMD + V during boot).

Someone please help. My Mac is not usable anymore. Boots in safe mode but freezes in safe mode too. From safe mode reinstalled Mavericks but failed again with same error.

If it can't be fixed please let me know if it can be reverted.

  • I did talk to Apple Support and problem is still unresolved. However it is found that Mavericks is not able to detect this SSD. Tried fresh installation from bootable 10.9 as well as net Recovery and that didn't detect Machintosh HD. Though safe boot works and it shows the disk. Disk utility from Safe mode reports no errors in HD and all looks good but somehow Mavericks is not able to detect this SSD. – Rajendra Patil Oct 24 '13 at 8:05

Let me answer my own question. Not really an answer to fix the problem but I found the problem and somehow could at least get back on Lion. I tried almost everything that I could think but none worked to get Mavericks on it.

The issue is Mavericks and Mountain Lion both somehow not detecting my Intel SSD.

I connected this mac in Target disk mode and could see it there. Ran DU checks and no issues reported. I then tried Mavericks installation from USB disk and then too it didn't find this disk.

I then formatted this disk from another mac (In Target) disk mode and started internet recovery. This time internet recovery started for Mountain Lion and that too couldn't detect this SSD same like Mavericks Internet Recovery as well.

Then I decided to go back to Lion and see if Lion installed/recovery detects this work and to my surprise Lion recovery detected it. So clearly some compatibility issue. I had no Lion installer on USB or elsewhere so I decided to install Lion on it from my another Mac's recovery.

I started it again in Target disk mode and connected it to another mac running Lion that I started into recovery. From there I could see this disk via firewire and then I installed Lion on it. After first reboot in between the installation I was worried if the installer continues on the same firewire "Macintosh HD" or goes into self "Macintosh HD" but it was proper.

Finally I rebooted both Macs with their own respective HDs as startup disks and both booted fine.

I still wonder what is wrong with my SSD that works for Lion but not for Mountain Lion or Mavericks. Not sure if it's SSDs fault or these latest OSes have dropped support for some SSDs or something like that.


I had exactly the same problem. First I installed Mavericks as an update. The installation process was successful, but at boot time it was freezing. Same after I reinstalled it.

Then I reformated my old partition, to be sure all old data was gone. I made a fresh installation of Mavericks and it works! At this moment my MBP with Maverick is restoring all my user data from the Time Machine backup.

Hope this helps.


Had the same problem with an Intel SSD in my 2011 17" Macbook. Worked fine under Lion, but Mavericks couldn't find it. I could solve it (after one week of wondering), by updating the firmware of the SSD to the most current provided by Intel. I wrote about the whole process in my blog, to perhaps help others with the same problem.

  • Welcome to Super User! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. Simply using this site to advertise your blog is not appreciated and risks your answers being deleted – Mokubai Nov 9 '13 at 19:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.