I just upgraded my MacBook Pro to Mavericks and my local Ruby on Rails development environment isn't running straight off the bat, when I visit localhost I see It works! and remembered I needed to start Phusion Passenger, so when I run passenger start it checks all the requisites and fails when it gets to the PCRE Development Headers:

 * Checking for PCRE development headers...
    Found: no

It tells me to go to http://www.pcre.org/ to download them so I downloaded 8.33 from here which went to my Downloads folder, so I unzipped it, cd'd to the folder and ran:

make install

Then cd'd back to my rails app directory on my Desktop and re-ran passenger start but it's still the same. Tried a new Terminal window but that didn't make any difference.

I must have done this before to get my dev environment working but can't seem to solve it this time.

I also tried brew install pcre but it says Warning: pcre-8.33 already installed.


The PCRE headers on Mac OS X should be installed in /usr/bin.

You could try adding that to your $PATH.

Another thing to try is explicitly calling it on the commandline: C_INCLUDE_PATH=/usr/bin/ passenger start

Lastly you could try reinstalling/recompiling passenger as it may not have groked where the PCRE headers are on your system.

| improve this answer | |
  • thanks, tried C_INCLUDE_PATH=/usr/bin/ passenger start but same result, will trying uninstalling and reinstalling passenger – martincarlin87 Oct 23 '13 at 12:23
  • reinstalling did the trick, passenger is now running but localhost is still saying It works! instead of showing my app, any ideas on that one? – martincarlin87 Oct 23 '13 at 12:26
  • Delete the index.html file in your app directory. – VogonPoetLaureate Oct 23 '13 at 12:40
  • thanks but there's no index.html file in the app directory – martincarlin87 Oct 23 '13 at 12:56
  • The "It Works!" message is an Apache default located in an index.html file somewhere in the web server's default root (where, depends on how your apache is configured). – VogonPoetLaureate Oct 23 '13 at 13:32

Found this fix at - https://stackoverflow.com/questions/19543094/apache-httpd-h-file-missing-on-macosx-after-mavericks-upgrade

  1. Update/install xcode
  2. run xcode-select --install- Update command line tools

Here are the remaining steps I took to get my site working.

  1. disabled/removed MacPorts/Fink
  2. brew install passenger - re-install homebrew
  3. rvm reinstall 2.0.0 or whatever version
  4. gem uninstall nokogiri - error with nokogiri
  5. gem install nokogiri
  6. bundle install
  7. restart terminal

and it worked! As a note, I am betting that if I had just installed passenger, RVM and restarted it would have worked after i did the xcode updates.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.