11

I normally have Active Window Tracking (XMouse) turned on in my Windows 8 machine. I wrote a small .Net utility to turn it on/off and adjust the delay. Works great!

After installing Windows 8.1, however, the ActiveWndTrackTimeout delay is being ignored no matter what value is in there. The window switch is occurring immediately regardless of the value in the registry:

ActiveWndTrackTimeout entry in my Registry

Has anyone else experienced this bug or have a fix for me? I can easily turn the feature on/off, but I'd rather leave it on with a reasonable delay.

I'm running Windows 8.1 Pro on a 64-bit machine.

8

I had Win8 and "ActiveWndTrackTimeout" was working fine, but when I updated to Win8.1 it stopped working. I had to RENAME "ActiveWndTrackTimeout" to "ActiveWndTrkTimeout", sign out and in, and now it works in Win8.1 too.

  • I had same problem with Windows 7 and this solution of renaming + restarting worked for me! Thanks! – J.D. May 10 '15 at 20:10
7

Maybe try ActiveWndTrkTimeout. http://technet.microsoft.com/en-us/library/cc957203.aspx

  • I've added in an ActiveWndtrkTimeout entry but it makes no difference, the windows switch immediately and ignore the value in the registry. I also tried removing the old ActiveWndTrackTimeout but still no change either. – Idle_Mind Oct 26 '13 at 5:19
  • My registry started with a value called "ActiveWndTrackTimeout" which had no effect. When I renamed it to "ActiveWndTrkTimeout" it worked for me (Windows 7). – Dave L. Dec 26 '13 at 17:53
2

Such an old question but still appears to be valid even for windows 10 (Seriously Microsoft you should fix it once and for all)

I started window 10 with Windows 10 1703 (15063.1387 - I don't think these minors are important).

I had configured: At path: HKEY_CURRENT_USER\Control Panel\Desktop\ value: ActiveWndTrackTimeout to 2000 (ms)

After upgrade to Windows 10 1709 (16299.461) everthing stopped working again. I haved added a registry DWORD key ActiveWndtrkTimeout with the same value (leaving the old key there) and the raise delay started to work again.

From the MSDN:

ActiveWndTrkTimeout

HKCU\Control Panel\Desktop

REG_DWORD
Milliseconds
0

0 is the default value.

Note: I want to get one disinformation corrected

There is also a registry entry MouseHoverTime at HKEY_CURRENT_USER\Control Panel\Mouse. This entry does not change the window raise delay. It changes how fast are the taskbar information & preview shown.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.