4

I tried to download OS/X Mavericks through the App Store yesterday. However, I had to leave work before it was done downloading and shut down the machine while it was downloading.

I assumed I'd be able to resume the download, or start over again later.

However, now there's no way to get it to download again. When I find OS/X Mavericks in the store, I click on the "Download" link. It asks for my Apple ID which I enter, and it does absolutely nothing. It doesn't begin downloading, and it just still shows the "Download" button. Clicking on it again does nothing.

I'm thinking there's something stuck somewhere, like some flag that says this download is in progress or it has already been downloaded. Is there some way to clear that out so I can start downloading it again?

1
  • Have you checked your Applications folder? Oct 26 '13 at 2:10
5
+50

Try checking your Purchases in the App Store to see if its there, if so you should be able to resume it and/or install it from here if its completed downloading. See https://support.apple.com/kb/HT4485.

You should also be able to clear a download from the Purchases section by clicking the 'X' which would appear next to the 'Status Button' of the item you wish to clear.

For example in the picture below if you hover your mouse over to the left of the 'Downloaded' button a 'X' should appear.

enter image description here

In your case that Status Button should say 'Resume', you can choose to resume by clicking on it or clearing it by hovering to the left of the button until the 'X' appears.

Failing that, call Apple customer service, they should be able to help.

EDIT: try checking for unfinished downloads via the menu bar and signing out/in and retrying the download.

App Store Menu Bar Options

EDIT: try checking and resuming the download in your Launchpad, progress should be shown on/in Launchpad. you can also delete the App in Launchpad by clicking and holding on the App until a close 'X' appears on the App. Then try re-downloading the App from the App Store.

Launchpad download progress

11
  • It shows up in the list, but doesn't say "Resume". I hit the "X" button which made it disappear. However, if I go back in the App Store and try to download it again, it still does nothing.. Oct 28 '13 at 18:14
  • Though it is a bit different now. Now, when I find OSX Mavericks in the App Store, it says Install App instead of Download. When I click on it, it asks for my Apple ID which I enter. Then, it does nothing. Oct 28 '13 at 18:18
  • @MikeChristensen - sorry for the late reply, although unlikely to help have you tried this: 1) Checking for unfinished downloads in the App Store menu (see the latest edit to my answer above) 2) Signing out of the App Store altogether and signing back in and repeating the download process.
    – tekiwibird
    Oct 28 '13 at 18:46
  • I tried your answer, but it didn't fix the issue.. Oct 28 '13 at 18:48
  • @MikeChristensen - have you checked your Launchpad? to see if the app is there?
    – tekiwibird
    Oct 28 '13 at 18:56
2

Might be a shot in the dark but quit the App Store, open up your terminal and run this:

sudo rm -rf /Applications/Install\ OS\ X\ Mavericks.app

It may have gotten corrupt and cant be overwritten when it tries to download again. Then open your app store back up and give it another shot. Also please be careful. The RM command is a powerful and dangerous tool. You should definitely have good backups :)

2
  • No such file. I ran the command anyway, and it didn't solve the problem. Thanks anyway. Oct 28 '13 at 18:10
  • Hm, Im not sure whats going on then. Have you tried downloading disk doctor from the app store, clear all of the caches and then redownloading? If that doesnt work maybe sign out of icloud, reboot, sign back into icloud, reboot and then try redownloading .
    – stevo81989
    Oct 28 '13 at 21:51
0

From Partial Maverick OS X download aborted, how to force re-download? :

I was having the same issue, and found a solution that does not require a reboot. Whenever I encounter an error in the Maverick download I,

Step 1: Copy (Cmd+C) the "OSX Mavericks" app package from the Applications folder

Step 2: Move (Cmd+Opt+V) it to another folder, say downloads

Step 3: Close Mac App Store

Step 4: Move the "OSX Mavericks" file back to the applications folder

Step 5: Double click "OSX Mavericks" and it resumes the download (rather than starting a fresh new download)

5
  • I don't have anything called *OSX Mavericks" in the Applications folder. Oct 28 '13 at 18:11
  • It might be called "Install OS X Mavericks.app". Otherwise you have deleted it by cancelling the download.
    – harrymc
    Oct 28 '13 at 18:20
  • Yup, nothing called *Mav* in /Applications - I definitely cancelled the download when I turned off the machine, I'm trying to figure out how to start the download again. Oct 28 '13 at 18:29
  • If Apple customer service cannot help, your other option is to find a Mavericks torrent and make yourself an installation dvd or usb, which would be quite legal in your case. Example : thepiratebay dot sx.
    – harrymc
    Oct 28 '13 at 18:32
  • Yea, I might just take it into the store. Apple Care is expired, so I'm not sure if they'd help me for free. They also might have install DVDs there, which I can't imagine would be very expensive. Oct 28 '13 at 18:35
0

Go to the App Store. Search for Mavericks. The little box will only say "Free" and nothing you do will get it to download. Instead, click on the Mavericks link to bring up the whole splash page describing Mavericks. The (larger) button now should say "Download" and will warn you that you already have Mavericks installed. Clicking on the Download button should start it downloading.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.