10

After switching browsers from Firefox to Google Chrome I've tried all the solutions that I know of, going into the registry and manually changing the default program there, going into the control panel and trying to figure out how to manually change the protocol, uninstalling Firefox completely, restarting my computer, downloading Default Programs Editor, and running every single one of these in administrator mode.

I STILL cannot get Chrome to open ANY hyperlinks in Skype or program links or anything that involves FTP, HTTP, or HTTPS protocol. I haven't even been able to find Chrome in the list of available programs that I'm allowed to set the protocol to. I'm getting pretty tired of even thinking about forcing the protocol as Google Chrome.

Here's an imgur album of the screenshots that I'd imagine would help: http://imgur.com/a/53NE5

  • To my knowledge, at 'install' Chrome will ask if you want to make Chrome as the default browser. (Press enter too fast) - If that doesn't work, go under Chrome Setting, and there is an option under Setting for Chrome to set itself as default browser. You may need to run Chrome as Admin for that to work. – Darius Oct 24 '13 at 0:57
  • 3
    I have a feeling that if something is messed up, you messed it up by doing things like playing with the registry. You should never have to do anything but set it the normal way. Try the normal method and see what happens. If it still doesn't work, try setting Firefox and IE as your default browser and see what happens. Normally. No registry or anything. Can you change it between those two? If so, you just might have fixed whatever you broke before. So try Chrome again now. If you find that Chrome is the only one that can't be set as default, then Chrome is the problem. Try reinstalling Chrome. – Ariane Oct 24 '13 at 1:00
  • 1
    I have the same issue as you, though I haven't been mucking around in the registry. – Rasmus Jun 25 '15 at 7:36
4

I had the same issue (Google Chrome not appearing in the default programs list) and it was caused by an incorrect registry value. This is what I did to solve it, which should hopefully work for you too:

  • Open the registry editor by pressing the Windows key + r, or by clicking on the Start Menu and searching for "run", and then type "regedit.exe" into the Run dialogue box.

  • Navigate to "HKEY_CLASSES_ROOT\chromeHTML\shell\open\command"

  • There should be one value in there: (Default) -- double click on it

  • Change the value data in the Edit String window that appears to match the location of Google Chrome's executable. And make sure to append -- "%1" to the end of the file location string. For me, this is what I needed to enter, including all the quotation marks:

    "C:\Program Files (x86)\Google\Chrome\Application\chrome.exe" -- "%1"

  • Click OK and reopen the Default Programs list. Google Chrome should now be listed there and can be set to default.

  • WORKED FOR ME!!!!! THX MAN! Been having this problem for 1.5y – 7h3w1z4rd Apr 21 '16 at 16:19
  • FWIW in my case the registry key path was HKEY_CURRENT_USER\Software\Classes\ChromeHTML\shell\open\command. For some reason I ended up with incorrect path to Chrome there and reinstalling or re-making it default browser did not help. Manually changing it as mentioned in above fixed it though. – elmo Apr 18 '17 at 9:18
0

There are several different places in the registry that need to be modified in order to set a browser as the “default”. It is not advised to modify these manually; instead you should let the browser itself decide what needs to be changed.

If you use Windows’ Default Programs function, you should use the Set Default Programs function to set associations by program rather than individually by type (figure 1).

Even better would be to just use Chrome’s own built-in association function by going to the page chrome://settings and clicking the button [Make Google Chrome my default browser…] under the Default Browser section.


Figure 1: Using Windows’ Default Programs function to set Chrome as the default for all types and protocols that it supports

Default Programs by program

  • 4
    It is pretty clear when you read the question that he can't find Google Chrome in the list of Default Programs. I myself have the same issue. – Rasmus Jun 25 '15 at 7:35
0

I've just faced the same problem. The reason is that I had installed Chrome as a normal user, not as an administrator. So when I opened it it told me it wasn't the default browser, and offered to set it as such, but it didn't work. And even going to Settings -> Make default didn't do anything. Google should really fix this so that you get a message that explains why.

The solution: call an administrator and ask him to reinstall it for you. In my case he could reuse the same ChromeSetup.exe file I had downloaded, and I didn't even need to close the browser during the installation - when he was finished I just closed the old one, then I started the new one, set it as default, and it worked. All the settings were kept, and even my session. I unpinned the old icon from the taskbar, pinned the new one, and that was it. It now appears in the list of programs that can be chosen as default, and indeed it is the default browser.

In your question you say that you tried to run it as administrator. You don't need to run it as admin, you must (re)install it as admin. Then you can run it with a regular, limited account and it will work.

-2

Reinstalling as administrator, works. Even if you are an administrator, try uninstall and run the chromeinstall.exe as administartor will work.

  • 1
    This duplicates another answer and adds no new content. Please don't post an answer unless you actually have something new to contribute. – DavidPostill Oct 13 '16 at 16:47

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.