I have tried to install the FBX Viewer application from Clockstone on two Windows 7 Professional 32bit systems. The installation completes on both machines but when I start the application I receive this error in a message box:

ViewFBX.exe - Bad Image

C:\Program Files\ClockStone FBX Viewer\d3dx10_43.dll is either not designed to run on Windows or it contains an error. Try installing the program again using the original installation media or contact your system administrator or the software vendor for support.


The error appears to reference a DirectX version 10 DLL. However I have version 11 installed on my system. Furthermore the application folder where the file in the error message is located contains version 9 and version 11 DLLs. If I remove the version 9 and 10 the error message changes to

...d3dx11_43.dll is either not ...

I have rebooted both machines and the error persists. I googled and found a few results suggesting that I "reinstall the latest direct x redist" which I did from this page. Rebooted and same error. I then tried updating my driver and although Device Manager reported I had the most current drivers I went ahead and downloaded the 140+MB Nvidia drivers and installed anyway. Rebooted and the error persists.

DXDiag isn't reporting any errors and simply says I have version: "DirectX 11". This page suggests that version 11.1 is the latest version I can run. I navigated to the KB article mentioned (KB 2670838) and installed the update. Rebooted and still the same error.

I'm ready to shoot something.

This is happening on my desktop and my laptop. Same OS but obviously different graphics cards. Anyone have any ideas? Is there a trick to FORCE install the absolute latest version of DirectX?

  • 1
    Have you tried manually extracting it from the DX CAB? -- How To Restore a Missing DirectX DLL File – Ƭᴇcʜιᴇ007 Oct 24 '13 at 5:17
  • This solution worked, thank you. That was also one of the better About.com articles I have ever used. If you want to submit an answer I will mark it as the solution. – Steve K Oct 24 '13 at 15:14

Try manually extracting the requested file directly from the DirectX installer CAB.


For more precise info and steps, check out this About.com article: How To Restore a Missing DirectX DLL File

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.