4

I have two D-LINK switches in my network, and I seem to have misplaced their IP addresses, so I can't remote on to them.

What can I do?

They both have DHCP disabled.

I've port scaned my network, and port 80 (i.e. the switchs' web interfaces) are not open on any IP that I can see :/

I have both devices' MAC addresses.

I have pinged my subnet's multicast (192.168.0.255), and then done an

arp -a

but the MACs aren't listed.

I've tried setting a connected machine's IP to

10.90.90.1

as the switches' default IPs are apparently 10.90.90.90 and repeated the above with no luck.

:/

Does anyone know how to factory reset either of these switches

D-LINK DGS-1210-24 
D-LINK DGS-1210-48 

?

Edit: Both switches are online and fully functional, I just admin access them!

Thanks

4
  • Perform a configuration reset, then set the IPs and other configuration, and document it this time? – Zoredache Oct 24 '13 at 18:29
  • Switches are not routers: they do not join two distinct networks, one on the WAN-side, the other on the LAN side. Thus they are not assigned IP addresses, they do not have NICs. – MariusMatutiae Oct 24 '13 at 18:31
  • 4
    @MariusMatutiae They are assigned IP addressed if they are active managed switches. The D-LINK DGS-1210 series certainly falls in that category. – Rik Oct 24 '13 at 18:35
  • ty for letting me know, I ignored they are managed switches. – MariusMatutiae Oct 24 '13 at 18:38
6

I think that should be D-LINK DGS-1210 series. (not D-LINK DSG-1210 ?)

If the DHCP-client on these switches are disabled you can't be sure on which IP they are. You could try the free Netscanner from Softperfect (my favorite for Windows) or use nmap 192.168.0.0/16 -sP on Linux (where 192.168.0.x is your current network). If that does not work you could try the same on 10.90.90.x.

But maybe you would have better luck doing a factory reset on these devices.

In the manual (do you have one?) it states you can press the Reset button (on the front) for 5 seconds to go to the defaults.

Support site for these are here. There is also the option to download the manual.

After resetting the device it will be on 10.90.90.90.

2
  • Thanks. Turns out, that Windows 8 doesn't like you changing its IP. did exactly the same actions on a Windows 7 and can connect straight away. fml – Andrew Bullock Oct 25 '13 at 12:39
  • Just tried Netscanner out; what a great tool! Thanks! – Steve Dowling Mar 8 '16 at 5:56
2

D-link offers a Windows executable called "Smart Console Utility" which allows discovery and configuration of the switches in your network. It also discovers the switches if they are not on the same subnet as the computer running the utility and then allows setting the IP, subnet mask and gateway addresses (which in turn allows access to the web GUI).

Download from the D-Link support web site

-1

Maybe the command

sudo arping ff:ff:ff:ff:ff:ff

can help you. ff:ff:ff:ff:ff:ff is a broadcast MAC address.

-4

Read the manual, it tells you how!

change your computers ip to 10.X.X.X, and subnet to 255.0.0.0 and leave the gateway blank.

go to your browser and type the address of the device 10.90.90.90 usually.

its all in the manual.......

1
  • Obviously he read the manual. But the ip could have been changed from someone else ! – Hadrien Huvelle Oct 17 '20 at 11:14

Not the answer you're looking for? Browse other questions tagged or ask your own question.