0

I'm working on a network management script with Dialog and I would like to suppress kernel messages from ifconfig and brctl so that they don't scroll the terminal and break the pretty Dialog screen.

I can redirect the easy things to /dev/null but I can't keep the info level kmsg stuff from printing to the console. The platform is headless and using syslog-ng to report to a remote server and I really don't need anything going to the console. Any solutions?

Trying to block messages like:

device eth0 left promiscuous mode
br0: port 1(eth0) entering disabled state
  • Have you considered changing permissions on /proc/kmsg? – MariusMatutiae Oct 24 '13 at 21:17
  • The permissions are read-only for root user only (400) normally, and changing them to 000 doesn't solve the problem. – Sam Oct 24 '13 at 22:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.