I set my BIOS to CSM only mode after being unable to boot into windows after upgrading it to 8.1 and not being able to boot from a USB stick to repair it.

I ended up putting in a formatted SSD, and managed to install windows 8 again from a USB stick. Only problem is I choose Windows 8 Pro instead of Windows 8, and so my key wasn't valid.

It's a Samsung series 9 laptop (NP900X4D), it tells me to press F2 for setup during boot, but no matter how many times I press F2 or any other key (F10, F12, DEL, etc) during the Fast boot , it doesn't show the the setup (BIOS) screen.

I don't get the option either when I use the windows Advanced Boot Options screen, I no longer have the option to boot from a USB drive, or to boot into the UEFI BIOS settings. I cannot even boot from a USB stick before windows loads up.

So I was wondering if there is a way for me to change the BIOS back to UEFI mode from CSM, without going through the BIOS, or if there is some other program that would let me load up the BIOS through some sort of USB tool I could boot from if I took out the SSD.

EDIT: Managed to get it working after installing an updated firmware for the motherboard from the Samsung site. The version that shipped wasn't responding to key strokes to allow me to enter the BIOS/UEFI.

  • You won't be able to change a BIOS setting outside of BIOS. A simple solution is to disconnect all the drives, change the setting, then connect the drives.
    – Ramhound
    Oct 25, 2013 at 15:13
  • Yeah but even when the SSD and USB stick are disconnected, I cannot get into the bios using F2 or any other key... It just goes to a screen saying no boot media could be found press F4 for recovery, and if it just reboots and does the same thing.... Oct 25, 2013 at 16:48
  • Contact Samsung's technical support. It sounds like they've designed their firmware very poorly, or at the very least in a confusing way, so they deserve the tech support call.
    – Rod Smith
    Oct 26, 2013 at 0:07

3 Answers 3


You may consider trying to do a completely fresh install with a different windows disk. Windows really like to mess around in the BIOS during installation, and if you can get it running, you can try to:

  1. Change the Bootup options from within windows, possibly by using bcdboot.exe.
  2. Restarting the PC by holding down [Shift] while selecting and clicking on the Restart option on the power-down menu. Your PC will restart into "rescue mode" and you will presented with a Windows boot menu, choose Troubleshoot >> Advanced options and then UEFI Firmware Settings.
  3. Update the BIOS by downloading it from Samsung support site, and flashing it, if available.

I had a similar problem while trying to install a flavor -- any flavor at all -- of Linux on my laptop, which came with an OEM copy of Windows.

The one tool (of many, many, many that I tried) that was able to help me get around my locked-down UEFI BIOS settings was a Linux Mint image, which included an installer that could run inside of Windows. Running that installer and then choosing (from within the installer) to restart in Linux Mint was enough to break me free of my UEFI prison.

I hope this helps somebody. Good luck!

  • 1
    How about you explain exactly what you did? Just telling us you used a Linux image to fix the problem doesn't explain HOW you fixed the problem.
    – Ramhound
    Oct 27, 2014 at 14:08

The way i was able to fix it was taking apart my laptop ( a series 5) removing the CMOS battery (its a little black circle connected by a red and black wire located above the ram slot to the right) and waiting a minute and putting it all back together. This reset by UEIF to defaults and booted me back up into windows.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.