1

I want to install php-soap, centos says:

[root@LMS-Cent64 soap]# rpm -ivh php-soap-5.3.3-22.el6.x86_64.rpm error: Failed dependencies:
        php-common(x86-64) = 5.3.3-22.el6 is needed by php-soap-5.3.3-22.el6.x86_64

after installing php-common(x86-64):

[root@LMS-Cent64 soap]# rpm -ivh php-common-5.3.3-22.el6.x86_64.rpm Preparing...               
########################################### [100%]
        package php-common-5.3.3-23.el6_4.x86_64 (which is newer than php-common-5.3.3-22.el6.x86_64) is already installed
        file /usr/lib64/php/modules/phar.so from install of php-common-5.3.3-22.el6.x86_64 conflicts with file from package php-common-5.3.3-23.el6_4.x86_64

What to do now?

1

If possible, use yum to update all your packages, and then use yum to install php-soap.

If you must install from an rpm, install php-soap-5.3.3-23.el6_4.x86_64 which is in the CentOS repo. Really should let yum or the graphical package manager handle all this for you though.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.