I was running Windows 8 on a Lenovo G780. After updating to Windows 8.1, WiFi does not work anymore - I always receive a "DNS server not responding" error. I have tried using public DNS servers from Google, and also restarting my router, but with no results. All other devices on my network are having no trouble at all.

I've tried updating the wireless driver, but the manufacturer's website claims that the Windows 8.1 driver should be updated with the update from Windows. So I can't find a wireless driver.

Anyone else having this error and does anyone have any ideas on how to fix it?

Here are the driver details:

Broadcom 802.11n Network Adapter

  • Provider: Microsoft
  • Driver Date: 2013-05-31
  • Driver Version:
  • Digital Signer: Microsoft Windows
  • 2
    Which driver do you have installed? The manufacturer driver or the Windows Update driver? Have you tried removing your driver and installing the one from Windows Update? – Josh Oct 25 '13 at 18:10
  • @Josh R I've reinstalled it using this method, still not working! I've edited my post with driver details – char1es Oct 25 '13 at 20:21
  • 1
    Here: Same Notebook, same Windows Version and same driver version. But .. not the same problem ;) WiFi-Networking sometimes (!) doesn't work, though connected to Router. Helps to disconnect and reconnect. The "only" other problem: Signal strength seems to be a bit lower than before (with 8.0) – igrimpe Oct 28 '13 at 16:14
  • Lenovo P400 here, and I have the same problem. I went directly to Intel's site to update the wireless drivers as Lenovo did not have current drivers for 8.1 for this model. I have installed the Intel drivers and rebooted yet the problem persists with the Wi-Fi connection going "stale" after a while. – jonsca Oct 31 '13 at 9:26

After further research i discovered a solution that worked for my particular device.

I followed these steps:

  1. Open Device Manager (search Windows Help if you don't know what this is)

  2. Select 'Network adaptors' and then open (double-click) Broadcom 802.11n Network Adaptor

  3. Go to the Driver tab and click the Update Driver... button

  4. Select 'Browse my computer for driver software'

  5. Select 'Let me pick from a list of device drivers on my computer'

  6. Select the "Broadcom 802.11n Network Adapter (Broadcom)" entry from the list

I used the Broadcom 802.11n Adapter version 5. Next restart and test.

Note: You must disable compatible hardware checkbox to find the previous versions of the driver

This solution uses the driver that was working before installing windows 8.1

UPDATE: After further testing i discovered that the broadcom 802.11n network adapter was actually limiting my connection speed. I am now using broadcom multiband network adapter with full speed

Source: denpsch

| improve this answer | |

You are using the generic Microsoft driver, which might be the problem.

Try to download the Lenovo driver for Windows 8.1 from Drivers and software - Lenovo G780 Notebook.

There are various variants to be found, for Atheros, Broadcom, Intel and Intel Wimax. Normally if you choose the wrong driver it will either refuse to install or won't matter, but you can find which is yours in Device Manager.

Reboot after the installation and re-verify the driver details.

| improve this answer | |
  • Thanks for the answer, but if you scroll down to the driver for Windows 8.1 LAN, you see that it is N/A (not available). Lenovo claims that the driver should come with the OS. And i really don't want to re-install seeing as i have nothing to backup on. – char1es Oct 31 '13 at 19:39
  • According to your post you should be looking at "Networking: Wireless LAN". This only has "Atheros WLan" for Windows 8.1, so I hope you do have Atheros. If not, you can try the driver from Windows 8 (and cross your fingers). – harrymc Oct 31 '13 at 20:04
  • yes i meant, wireless LAN ;) I have a Broadcom adapter, but i will try the atheros. If atheros doesn't work ill try win8. Will post updates – char1es Oct 31 '13 at 20:47
  • atheros for win8.1 didnt work, neither did broadcom for win8 – char1es Nov 1 '13 at 15:25
  • 1
    If you have a Broadcom card, only its driver has a chance of working. As you found a better driver on Windows, it seems like the Lenovo drivers are to be avoided unless absolutely required. At least my analysis of the problem was correct, but drivers are always a hit-or-miss thing. – harrymc Nov 1 '13 at 17:54

Same problem on my Lenovo L530 with Win 8.1. Multiple Lenovo reps no help at all. Got answer at Tom's Hardware, that the updated drivers from Intel won't work with Win 8.1. I emailed Intel, got no reply.

The fix, roll back to the original Windows driver from MS as installed on the machine

| improve this answer | |
  • Yes, this is what my answer does through a step-by-step procedure – char1es Feb 26 '14 at 19:38

For me, problem got solved by disabling WMM on the router.

| improve this answer | |
  • While it may solve the problem in question, one line answers are generally not a good fit here. It would be appreciated if you could find out why disabling that option worked for you, thus creating an understandable solution. – Doktoro Reichard Apr 12 '14 at 23:44

Not the answer you're looking for? Browse other questions tagged or ask your own question.