0

I had fedora dual-booted with windows on my laptop for a while but with windows refresh grub was gone and my system directly booted windows. I booted fedora with my systems boot options and with this tutorial: https://fedoraproject.org/wiki/GRUB_2 I reinstalled grub2 but then had my system booted into an empty grub prompt: grub> So I found the drive containing vmlinuz and initramfs (completely sure about thair location and versions) and tried to manually boot it but after the boot command it said:

no suitable video mode found

booting in blind mode

and nothing happened.

Such a tragedy...

I have already tried to use live disks rescue system. Funny but troubleshooting options don't apear on my laptop while they do on my desktop pc. I cant even go to boot prompt on my lenovo idepad z400 laptop.

I also tried EasyBCD so maybe I could boot it with windows but it comes up with this error:

missing AutoNeoGrub().mbr

Now I have removed the grub prompt (don't know why) and its really hard for me to reinstall my dearly customized fedora. If anyone knows a way to help boot it again or reinstall it keeping my files and installations I really need it.

Thanks

PS:I have already tried Boot-repair Disk but it asks me to enable the repo containing grub-efi on my fedora to reinstall the grub2 and fix the boot for me (how could i?).

  • Are you using UEFI, SecureBoot, or FastBoot? Also are you using LVM? – ChasingLogic Oct 26 '13 at 15:46
  • I never used any of them – Parisa Oct 26 '13 at 15:48
0

I've had great success with SystemRescueCD. They even have a webpage devoted to your problem of having to fix a broken GRUB to rescue the Linux system.

www.sysresccd.org/Sysresccd-Partitioning-EN-Repairing-a-damaged-Grub

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.