I've been searching high and low for someone who can help me.

I've been trying for a month. A month. to install Java on my new PC to no avail. No tech support forum can seem to help me.

It all started while playing tekkit one day. I kept running out of memory (using the 32-bit JRE 7 u45) so I decided to install the 64-bit version. I uninstalled the 32-bit version first, for some reason, and downloaded the 64 bit runtime. In the installer, I go through all the normal screens until the installation progress bar appears. Then, it just sits there. No progress is made. No CPU is used by the installer, or any of its dependencies.

The installer will stay like this for hours, days, and in one case a whole week without doing anything at all. I've tried installing older versions, the 32-bit version, even Java 6 and none of them will install. UAC is disabled, I've run regedit, CCleaner, and any other "fix-it" program there is. It's getting to the point where I may just have to wipe my hard drives and start over.

I have several applications that require java, so this is an absolute necessity. Please, please, someone have the answer.

Here are my system specs:
-Intel i7-3770k
-AsRock z77 Extreme3
-Samsung 840 pro SSD
-WD Caviar Black 1tb

  • Windows Users: Improve the security of your computer by checking for old versions of Java and removing them using the Java Uninstall Tool. java.com/en/download/faq/remove_olderversions.xml – Logman Oct 27 '13 at 2:46
  • Just curious, what version of tekkit are you playing? – Jon Oct 27 '13 at 3:14
  • I can't use the uninstall tool because Java isn't installed in the first place. And I don't even remember what version I was using but it doesn't matter because I removed every trace of minecraft just to get Java to install. – Patrick Oct 27 '13 at 16:21

I had to disable Microsoft Security Essentials to get JDK installed recently. The installer exited with an error message about cab file checksums or something.

You could try the following steps:

  1. Disable your antivirus
  2. Install JRE or JDK (I'm using JDK)
  3. If regular java doesn't install, you can try installing jPortable, which also has a 64-bit version
  4. Add C:\Program Files\Java\jdk1.7.0_25\bin (or similar) to the beginning of your path (DON'T REMOVE OTHER STUFF THERE)
  5. Run the .jar file from command line with java -jar filename.jar

Adding java bin to your path isn't necessary but it makes running java from command line easier and is resistant against incorrect "default program" settings.

  • Kudos for the tip about disabling Security Essentials (eg. Defender), that just helped me fix a cab checksum error for a VC.80 C++ 2005 redist binary on windows 8.1 for some other app! – mtone Oct 27 '13 at 3:29
  • Tried these, still didn't work. The installer still hangs right when it starts to install. It's like it's trying to write the files but it can't. – Patrick Oct 27 '13 at 14:58
  • @Patrick Added link to jPortable. If it comes to reinstalling Windows, with Windows 8 you can also "refresh" the installation without removing your files – siikamiika Oct 27 '13 at 23:56
  • Well, it looks like jPortable will work for now. Thanks a bunch. Hopefully it'll work for all the jars I need to run. – Patrick Oct 28 '13 at 0:26
  • @Patrick I'm not sure how jPortable works with browser applications and I think it doesn't update itself automatically but it should be identical to normal java when running jars – siikamiika Oct 28 '13 at 0:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.