I can't start MYSQL.

I changed a parameter in WEBMIN in the main mysql configuration:

SKIP LOCKING OF TABLE FILES?... the original value was "NO", and I changed to "YES"

This is the LOG file:

131026  1:12:27 [Warning] Using unique option prefix myisam-recover instead of myisam-recover-options is deprecated and will be removed in a future release. Please use the full name instead.
131026  1:12:27 [Note] Plugin 'FEDERATED' is disabled.
131026  1:12:27 InnoDB: The InnoDB memory heap is disabled
131026  1:12:27 InnoDB: Mutexes and rw_locks use GCC atomic builtins
131026  1:12:27 InnoDB: Compressed tables use zlib 1.2.3.4
131026  1:12:27 InnoDB: Initializing buffer pool, size = 128.0M
131026  1:12:27 InnoDB: Completed initialization of buffer pool
131026  1:12:27 InnoDB: highest supported file format is Barracuda.
131026  1:12:27  InnoDB: Waiting for the background threads to start
131026  1:12:28 InnoDB: 5.5.34 started; log sequence number 9992525
131026  1:12:28 [ERROR] /usr/sbin/mysqld: unknown option '--skip-locking'
131026  1:12:28 [ERROR] Aborting

131026  1:12:28  InnoDB: Starting shutdown...
131026  1:12:29  InnoDB: Shutdown completed; log sequence number 9992525
131026  1:12:29 [Note] /usr/sbin/mysqld: Shutdown complete

The problem is in [ERROR] /usr/sbin/mysqld: unknown option '--skip-locking'.

So, my file "my.cnf" is good, because it says this:

[mysqld]



user        = mysql
pid-file    = /var/run/mysqld/mysqld.pid
socket = /var/run/mysqld/mysqld.sock
port = 3306
basedir     = /usr
datadir = /var/lib/mysql
tmpdir      = /tmp
lc-messages-dir = /usr/share/mysql
skip-external-locking

Please I need help tp restart mysql.

Thank you soo much for your time and help

migrated from stackoverflow.com Oct 27 '13 at 9:59

This question came from our site for professional and enthusiast programmers.

  • What is your version of MySQL ? – Basile Starynkevitch Oct 26 '13 at 4:31
  • My version is Mysql 5.5 – Diego Morales Sepulveda Oct 26 '13 at 12:57

Looks like your MySQL doesn't support this flag. Have you tried to change this option back in webmin? If it doesn't help, try to look at /etc/init.d/mysqld and /etc/default/mysqld (I'm not sure about filenames). Look there for args for daemon.

  • I tried to change the value on webmin, but it's imposible because the server don't start, so, webmin can't manage the options. – Diego Morales Sepulveda Oct 26 '13 at 12:59
  • As I already said, try to look at /etc/default/mysqld (I'm not sure about filenames). Look there for args for daemon. – Anton Balashov Oct 26 '13 at 15:53
  • Thanks. I tried to open this, actually it was the first file to looked, but i cant open it with an editor, gedit or other. – Diego Morales Sepulveda Oct 26 '13 at 18:03
  • Try to be more informative and I'll be more usefull :) Why you can't open? Did you try root? Open terminal and exec: sudo -i, cd /etc/defaults, ls, find the conf for mysql and open it by nano <file>. Find and remove your flag there. Or try to run MySQL manualy with out this flag and try to find it in webmin after that. – Anton Balashov Oct 27 '13 at 5:14

Ouich! So bad! The flag skip-locking was renamed skip-external-locking in MySQL 4.0.3 (see this list), and untill now no one has told the guys at webmin to change it.

By the way this is the default behaviour, and this flag doesn't change anything, see actual MySQL doc here. May be that's why no one bothered about this.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.