4

Yesterday, I upgraded my Mac to Mac OS X 10.9 (Mavericks), and since then I couldn’t open the “Terminal,” each time I open a session, the following error is shown:

[Could not create a new process and open a pseudo-tty.]

[Command not found: tmux]

I don’t know what's causing this issue and a fresh restart and killing the relevant processes on activity monitor doesn’t help. Any thoughts?

3
  • The upgrade reset you /bin and /usr/bin etc., if you installed software there, it's now gone.
    – Daniel Beck
    Oct 27 '13 at 14:24
  • Hi Daniel, so what should be done? Thanx.
    – Malloc
    Oct 27 '13 at 16:56
  • 2
    Don't automatically run tmux when opening the Terminal, instead, run a shell like bash.
    – Daniel Beck
    Oct 27 '13 at 17:56
5

It might be a simple and going into Preferences/Startup/Shells open with and select 'Default login shell'.

It is related to where the Shell you are opening, and you can have multiply shells (but that is another thread'

2

I was getting similar error. So to fix it, within Terminal, I opened

Preferences > General

and set

'Shells open with': to 'Default login shell'.

I then quit and started the terminal app again and the error was gone.

Hope this helps.

1

I got this error after upgrading from Lion (10.7) to Mavericks. (10.9) This fixed it: Go to Terminal > Preferences > Settings > Shell and uncheck "Run command".

0

Do this terminal>preferences>general>shells open with then click on "default login shell"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.