4

So, I'm trying to update Windows 8 to Windows 8.1 via the Windows Store, but every time I attempt to, the update downloads properly, but then I get the error:

Windows 8.1
This app wasn't installed - view details

When I click on it, it says:

Something happened and the Windows 8.1 could not be installed. Please try again. Error code: 0x80070004
Try again Cancel Install

What does this mean? A quick Google search yields nothing.

I have tried rebooting, clearing the store cache, and resetting Windows Update. All Windows Updates were installed. I have tried using a different administrator account, and it does not work.


A quick chkdsk scan shows no errors.


A SFC scan now shows no errors.


I found the error log!

http://pastebin.com/BXZEsejm

Why is the registry corrupt?


DISM Results

Checking System Update Readiness.


Summary:
Operation: Detect and Repair 
Operation result: 0x0
Last Successful Step: Entire operation completes.
Total Detected Corruption:  0
Total Repaired Corruption:  0
    CSI Store Metadata refreshed:   True

Total Operation Time: 1405 seconds.
  • The 0x80070004 error is "ERROR_TOO_MANY_OPEN_FILES". Not overly helpful up front. :) What have you tried already? For example: Have you tried restarting and trying the update again? – Ƭᴇcʜιᴇ007 Oct 28 '13 at 0:28
  • It's not be that literal. ;) It's more likely too many open file by that one process (the updater). If you've tried rebooting (you haven't said what you've tried yet), also try resetting Windows Update, and reset the Store cache. – Ƭᴇcʜιᴇ007 Oct 28 '13 at 0:41
  • @techie007 I have now tried all of those and am still getting the same error. – user140967 Oct 28 '13 at 21:50
  • If you haven't already, do some disk checks. From here on, I suggest you Edit your question and update it to include what you've tried, and what the results were. Hopefully that'll help someone recognize what's going on without suggesting things you've already tried. But that's a weird situation for sure, an di don't have any specific answers. If the disk checks come up clean, it might be worth contacting MS' support about. – Ƭᴇcʜιᴇ007 Oct 28 '13 at 23:01
  • @JeffreyLin have you moved any user profile to other disk rather than default location of C:/? If yes most probably this is the culprit in your case as many other user have confirmed this. From here and here – avirk Jan 1 '14 at 4:58
4
+50

You seem to have problems in Windows 8. There is no point in trying to upgrade to 8.1 without fixing them first and verifying that "sfc /scannow" passes without errors and also that Windows Update is functional and can fully patch your Windows installation.

Some utilities that could help you check for problems are :

If none of them helps, Do a Repair Install of Windows 8 without Losing Anything.

The next step is to verify if your user profile got corrupted. Follow the instructions in the article How to fix corrupt user profile in windows 8 to create a new administrator profile and see if it can do better than your old account.

If nothing helps, my remaining advice is to look up the article How to refresh, reset, or restore your PC. If the problem is recent, try first to restore to a system restore point that dates from before the problem appeared. If that doesn't help, then try a Refresh, with a Reset as the last possible action. If Reset does not work, reformat the disk and reinstall Windows 8 from DVD or USB.

In all cases, ensure before starting that all your data is safely backed up.


Once "sfc /scannow" and Windows Update pass without errors, follow the steps outlined in the article :
Fix: Your Windows 8.1 install couldn’t be completed error.

In a nutshell, the instructions are to open a Command Prompt as administrator, then enter :

net stop wuauserv
net stop bits

Then browse to the C:\Windows\SoftwareDistribution folder and delete all the files and folders inside (restart if in use).

Then enter the following commands :

net start wuauserv
net start bits

Now open the Windows Store and try the upgrading process all over again.


If you still have errors with the Store, some advice :

  • Disable all security products
  • In Command Prompt (cmd) Run as Administrator, execute WSReset.exe to reset the Store
  • I see that sfc now works, so I added a second part to my answer. Your comments are welcome. – harrymc Jan 6 '14 at 9:51
  • See the article How to Install Windows 8.1 Update When Missing From Store. The best advice there is installing KB2871389, but you should do Windows Update for ALL mandatory AND optional updates before attempting 8.1. See also Why can't I find the update in the Store?. – harrymc Jan 7 '14 at 8:10
  • These are useless, no point. Have you tried the links in my above comment? – harrymc Jan 7 '14 at 22:26
  • I believe the problem started a long time ago. I had created a new user profile for some reason, and then migrated all my user data. I changed the user profile name and then messed with the stuff in the registry. Could this be what is causing the problem? – user140967 Jan 7 '14 at 22:38
  • Probably in c:\windows\setuperr.log, please post if not empty. Have you tried (1) stopping all security products, (2) in cmd run as admin run WSReset.exe, (3) another administrator account. See also this link. Have you maybe displaced your user profile from C: to another disk using a symbolic link? – harrymc Jan 8 '14 at 6:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy