10

I have an SD card, that is broken, the slider for the "Lock" is gone. When I put it into my computer it turned out to be in read-only, How can I override this with software? I need to format the SD card. I am using Ubuntu and Windows 7

  • After reading the unsuccessful answers so far, one question comes up: where does this card from? Specifically: was it writable before? If the file system on the disk says "you can't read me", you have two things to fix. – Jan Doggen Nov 15 '13 at 7:50
  • yes it was write-able. It is a San Disk Extreme SD card, The file system is FAT32, My computer can read it fine. – Vader Nov 15 '13 at 12:12
6
+50

From sd card reader not working :

I found that unlocked, my Eye-Fi card should only be inserted 20-22mm into the card reader (not all the way). Locked, it seemed to work fine inserted all the way.

image1


Another solution from Repair missing SD-card lock :

  1. Get a piece of aluminum foil and stick it onto a piece of tape then put it on SD :
    image2

  2. Cut a straw into pieces that can fit into the hole of the Lock and fill the hole with them and cover with the other end of a scotch-tape. Use 2-3 pieces of straw :
    image3

  3. Insert into the card-reader :
    enter image description here

| improve this answer | |
  • I tried this, it does not work, thats why I am asking for a software way of bypassing it – Vader Nov 12 '13 at 21:42
  • Try using the card with another reader, computer or operating system. Try a Linux live CD as described here. If nothing works then the card is defective and is a lost cause. – harrymc Nov 13 '13 at 8:53
  • this is the closest thing to an answer that I am going to get. – Vader Nov 18 '13 at 16:30
5

The write protection tells the computer to reject all write requests, which normally prevents writing to the SD card. Unlike the floppy disk, this is done at the software level. Although the card reader can detect the position of the read-only switch, the switch itself doesn't physically hinder writing. This means that although it's theoretically possible to write onto a read-only card, it would have to be at a low level. Barring direct manipulation of the output bits, the only permanent solution would be to format your card at a low level, thus removing the card-side write protection.

This is not the same as a normal formatting. It wipes the card completely, including the protected areas, where the write-protection securities would be held. Theoretically, this would erase the card's write protection, but it may also come with unforeseen complications if done incorrectly. I would suggest that you only use a low-level format if you know exactly what you're doing. There is a free low-level format tool compatible with SD cards available at this link: http://hddguru.com/software/HDD-LLF-Low-Level-Format-Tool/

It should be noted that this needs to be done in conjunction with one of the hardware solutions posted here. Again, SD card readers are designed so that they can detect the position of the switch. If the hardware solution doesn't work (as is the case here), then the card must also have a built-in write protection.

| improve this answer | |
3

I'm fairly certain that the lock is a physical mechanism, and therefore all you need to do is put a piece of scotch tape over the SD card. Be very precise in placing the tape over the notch, but not over the brass connector on the opposite side.

SD card with tape

The notch forces the read-only to work with camera's, PDA's, MP3 players, etc, however they are not guaranteed to work on all SD readers (apparently it works on your reader). It's simply a physical thing, therefore the tape will trick the SD card reader into thinking the SD card is unlocked.

| improve this answer | |
  • DOes not work, fiel system is still read only – Vader Oct 29 '13 at 11:53
  • I think it is more sophisticated than a light blocker. – Vader Oct 29 '13 at 13:51
  • Just tried with a SD card with lost lock pin. Precisely taped a harder plastic there and voilá. It writes! – Fusseldieb Sep 15 '19 at 19:33
0

If I'm not mistaken - its the same kind of thing as the old floppy disk. The lock blocks a lightbeam if it is in the correct position. There's no electrical component to it - just that if the switch is in a certain spot, the lightbeam gets broken and you can read and write. Otherwise it is write only. I'd try and tape over the switch area with something like scotch tape and darkening it with a sharpie. Really, though, they're so cheap it would be better to just replace the card. I'd worry about the tape pealing off inside the SD card slot and then you might end up really screwed.

| improve this answer | |
  • 2
    I don't believe that the lock mechanism for SD cards is a literal lightbeam, but it could certainly be something that was implemented in hardware. At best it might be overridden at the driver level. I'd advise against continuing to use an sd card that has been physically damaged. – Fopedush Oct 28 '13 at 22:39
  • I do not see a whole in which the light could enter. – Vader Oct 28 '13 at 22:47
  • Put card on the table. Align it so the part you insert is facing away from you and the gold fingers face the table. The switch should have been on the left edge of the card. There may be a notch on the left side towards the edge you insert. Tape that area and darken it. If you are confused, you can search youtube - there should be a couple of examples. – Blackbeagle Oct 28 '13 at 23:10
  • 2
    @Fopedush The switch is purely mechanical and should (by the standard) not affect what the card itself chooses to do. It's up to the reader to decide how the detection of the switch is made. Some might use a small IR LED and sensor, whereas other use a mechanical switch in the slot. here is a look inside an SD card slot component which shows an example of how the reading can be implemented using a spring contact. As long as you can replicate the effect of the switch, it should work. – nitro2k01 Feb 22 '14 at 16:55
0

there is no light beam in an sd card reader. the lock is a little switch which CLOSES when the plastic sliding lock is forwards (towards the contacts).

tape over the slot only with scotch tape and the switch may be weak enough to activate, thus closing the circuit and allowing the card to write.

i am finding a way of taping a little piece of wood to fill the slot ( a thin sliver of wood such as that off a matchstick ) as the switch in my camera requires a lot of pressure to activate it. its not working in my camera because the tape gives a little under pressure and doesnt push the switch closed. it needs something in the slot to be taped there.

method 2: i am now using some semi-hardened gorilla glue and building it up thus removing the indentation on the side of the card completely.

leave the glue for a while to become mostly hard, perhaps an hour or more, and then using a sharp hobby knife ensure its a flat surface by scraping the excess off with the knife.

i allowed the gorilla glue to become opaque and thick before trying to apply it to the card, that way it becomes thick enough to stay put and not run out of the groove. in 18C temperature that took about 10 minutes to go opaque and get thick enough to paste it into the groove.

note: test the glue is stuck firmly to the card when its cured. if the glue drops off into your electronic equipment, it may cause havoc !!! if you are unsure of this method or unsure of the bond between the glue and the card, DON'T DO IT this way as i won't be responsible for the loss of your equipment - do it at your own risk. (but gorilla glue is good stuff. if the card is not greasy it should stick well).

| improve this answer | |
0

TRICK DOESN'T WORK ON APPLE MACBOOK or iMAC and technically, it shouldn't work on any SD slot, there's no such thing as a "light beam", it's a very simple metal pins mechanism. I had the same issue, tried the tape, tinfoil and mid-position tricks to no avail so I looked it up:

IMage
(source: engineersgarage.com)

I used a led light to see inside the slot and it was all in fact, pins. a pin is pushed when the card slider is in "lock" position preventing the OS from writing. I used tweezers to scrub inside the lock recess in the iMac slot, plugged the SD afterwards and it worked. might have been jammed with dirt and dust.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.