0

Any executable that I attempt to run on this laptop pops up an error stating The program can't start because LPK.dll is missing from your computer. Try reinstalling the program to fix this problem.

I have tried doing regsvr32 lpk.dll from within system32, but that returns the error The module "lpk.dll" was loaded but the entry-point DLLRegisterServer was not found. Make sure that "lpk.dll" is a valid DLL or OCX file and then try again. I was able to copy the DLL file from a working computer, but I get the same issue.

How would I go about registering this DLL? Or, alternatively, which program would I have to reinstall to get the DLL to work again?

The system is Windows 7 Professional 64-bit with Service Pack 1. I would really like not to reinstall the OS, but at this point, I'm about ready to.

  • support.microsoft.com/kb/249873 – TheSAS Oct 30 '13 at 15:30
  • Maybe this topics should be linked together stackoverflow.com/questions/4897685/… – TheSAS Oct 30 '13 at 15:30
  • @TheSAS Thanks, but that doesn't really help. Both the regsvr and the dll are in the same folder (system32). When I try doing the sysWOW64 to register the dll, I get regsvr telling me that lpk.dll is missing from my computer. This isn't an issue of 32- vs 64-bit implementation. – Kruug Oct 30 '13 at 15:43
  • note that many dlls are not system registrable, and when you attempt to regsvr32 them, the error you posted is the standard response. also, copying system dlls between computers is a bad bet, unless you can confirm that the file is of exactly the same version on both boxes. – Frank Thomas Oct 30 '13 at 15:44
  • @FrankThomas That might be the issue I ran into with copying, then. I copied from Win7 Ultimate 64-bit. I did make a backup first, I'll try restoring that file and regsrv'ing again. – Kruug Oct 30 '13 at 15:48
1

run cmd as administrator and run sfc/scannow.

Looks like corrupted system file.

  • Note, be sure to close any programs you have open before running a system file check. – Frank Thomas Oct 30 '13 at 15:41
  • Attempting to run the command sfc /scannow returns The program can't start because LPK.dll is missing from your computer. Try reinstalling the program to fix this problem. I ran scandisk, and that found some corrupted sectors, so how would I fix that? I did copy the new dll after I ran scandisk. – Kruug Oct 30 '13 at 15:46
  • chkdsk -R c: will attempt a disk scan with bad sector check on the c drive. since it will likely be mounted, you will probably be prompted to perform the scan on next boot automatically. then just reboot. – Frank Thomas Oct 30 '13 at 15:53
  • I apologize, that's what I ran, not scandisk. – Kruug Oct 30 '13 at 16:02
  • did you use the -R switch? -R or -B are required to search for bad blocks. also note that chkdsk and sfc do entirely different things. I've seen corobboration that the sfc /SCANNOW has fixed other folks problems with missing language pack dlls. answers.microsoft.com/en-us/windows/forum/… so I'm surprised it gave you that error. – Frank Thomas Oct 30 '13 at 16:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.