Yesterday I attempted to upgrade to Windows 8.1 from Windows 8. My brother downloaded it on his computer the day before and I got it from the Windows store. It downloaded and prompted me to restart, so I did. It just had the windows 8 loading screen with the HP sign above it, no percentages or anything else. I waited for about 2 hours and while I was waiting I did some research. After reading I saw it could take 20 minutes to an hour to update, but it had already been 2 hours. I read another article and it said someone restarted their computer and it restored to windows 8.0. That's what I did and it worked. So I tried again and the same thing happened. Instead of waiting I decided I would just restart it again.

I tried again and this time it showed a percentage and it said "Setting Up". After it reached 100% it went back to what happened before, showing the HP sign. I restarted the computer and thought it would be different this time because it did show percentages. I waited an hour and nothing happened so I restarted the computer again. This time when I restarted it, it didn't restore, so I turned the laptop off for around 30 minutes, turned it back on and it said "Attempting to restore to previous version of Windows". It said that for around 10 minutes and it restored it. I shut down my computer for an hour and did some more research. Later I found that I needed to update my drivers. My drivers we're updated so I did some more research. After this I saw I needed to search for updates via: Settings -> Change PC settings -> Windows Update. It said I already had automatic updates on so I decided to check for updates and it said there was one update scheduled for Saturday. I didn't think this would change anything so I updated what I could. I tried to install it again. It was around 11:30 last night when it was done downloading and it prompted me to restart but I had gone to sleep. I woke up today and saw it showed the HP sign and loaded again. I tried restarting it again but this didn't work. I had to shut it off for 30 minutes and try again and it worked. So now I'm posting this seeing If I can get any help with this problem. Any help is appreciated. Thanks!

  • This is a very verbose question, take a look at this – Jason Bristol Oct 31 '13 at 15:55
  • @JasonBristol This is all that has happened I need to tell the whole story for the whole help.... – user52428 Oct 31 '13 at 16:04
  • 1
    @user52428 - Have you updated the BIOS revision. Have you contacted HP about perhaps a known conflict with Windows 8.1. While Windows 8.0 and Windows 8.1 I have found their drivers are NOT compatiblew ith one another. Comes down to the fact the Windows Driver Model was updated with Windows 8.1 – Ramhound Oct 31 '13 at 16:09
  • @Ramhound I have not contacted HP as a didn't think it would be necessary. Also I don't know what a BIOS is, looking in to it right now. I'm just a kid man! – user52428 Oct 31 '13 at 16:14
  • @Ramhound Thanks man! I found more than just BIOS updates, think this will fix my problem! – user52428 Oct 31 '13 at 17:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.