14

My Chrome settings says "Google Chrome is not currently your default browser." But there's no button that allows me to set Chrome as the default browser:

enter image description here

Running Windows 7 x64. Absolutely baffled. Can't seem to find anything on Google. "Run as Administrator" doesn't change anything. IE and Firefox both have their "Make default" buttons present, so I don't think it's a network policy thing? Tried setting FireFox as the default then coming back to Chrome; still nothing.

  • How did you install chrome? I know that when you are using a portable version of chrome you cannot set it as default. – Ben Franchuk Oct 31 '13 at 20:42
19

Try the following.

  1. Press enter image description here key to get search box. Type default and you’ll get Default Programs as a result.
  2. Select Google Chrome and click Set this program as default. Click OK.

enter image description here

  • Hmm, if I click a link in an email or something, it'll open in Chrome but if I look at my registry HTTP\\shell\\open\\command is still set to FireFox... Would it be a bad to delete that and put in the path to Chrome? We've got an application at work that uses this key and I don't want it to keep opening FireFox, but at the same time I don't want to remove FF from my system all together. – sab669 Oct 31 '13 at 20:59
  • This is not answering the question. Sure, you can do it the Windows way, but why is the option not available in Chrome Settings? – Pacerier Nov 5 '15 at 19:38
1

I had the same issue, and I installed chrome again (without removing the first installation), this time by the offline standalone setup, for all users. I now have two chrome installations. I deleted the old one, which didn't delete my history/passwords/bookmarks. But I now have chrome as default browser, and it also showed up in default programs window, which it wasn't before.

1

On a Mac, click on "System Preferences -> General -> Default web browser" to pick the browser. I'm on OS X El Capitan.

  • Please read the question again carefully. Your answer does not answer the original question. OP is using Windows not Mac. – DavidPostill Jan 19 '17 at 10:01
  • 1
    I know the question was for Windows, but I had the same problem on my Mac, so I put the answer here to help other Mac users. – Raymond Gan Jan 19 '17 at 15:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.