I've used Google Drive for awhile now, but it won't start up after installing on my latest system re-build. I'm still using the same OS, hardware, and basic software load (antivirus, firewall, etc.) that I have for years during which I had not previously had problems with Drive.

OS: Windows 7 Ultimate x64
Google Drive Version: 1.12.5329.1887

Now, whenever I try to run Google Drive, it just spawns two instances of the executable which die shortly after. No error messages are posted to the desktop, and nothing indicating any problem is written to the Event Log.

After some research, I've yet to find anyone having the same problem who's found an answer. I did find out how to run Google Drive in diagnostic mode, using the --vv parameter at the command line. After that, I opened up the sync log and got this:

2013-10-31 17:11:24,039 INFO pid=3664 1892:MainThread      logging:1600 OS: Windows/6.1.7601-SP1
2013-10-31 17:11:24,039 INFO pid=3664 1892:MainThread      logging:1600 Google Drive (build 1.12.5329.1887)
2013-10-31 17:11:24,039 DEBUG pid=3664 1892:MainThread      logging:1608 DEBUGGING DUMP is ON.
2013-10-31 17:11:24,051 ERROR pid=3664 1892:MainThread      logging:1575 ERROR, UNEXPECTED EXCEPTION
2013-10-31 17:11:24,051 ERROR pid=3664 1892:MainThread      logging:1575 [Error 5] Access is denied
Traceback (most recent call last):
  File "<string>", line 232, in Main
  File "<string>", line 118, in RegisterCustomFileTypes
  File "P:\p\agents\hpal4.eem\recipes\353983091\base\b\drb\googleclient\apps\webdrive_sync\windows\build\pyi.win32\main\outPYZ1.pyz/windows.registry", line 62, in GetValue
WindowsError: [Error 5] Access is denied
2013-10-31 17:11:24,052 INFO pid=3664 1892:MainThread      logging:1600 Crash reporting disabled. Ignoring report.
2013-10-31 17:11:24,052 INFO pid=3664 1892:MainThread      logging:1600 Exiting with error code: 0

I'm running on an account with Administrator-level permissions, and have even tried using "Run As Administrator" on the EXE. I'm not sure why it's looking for a P:\ drive, as no such volume has ever been mounted on this system.

What should I do to try to further troubleshoot, and resolve, this issue?

  • 3
    I would try ProcessMonitor from Sysinternals, to find out wether there is a problem with permissions or bad path. That non-existent path P:\... is from developers PC. – week Oct 31 '13 at 21:33
  • @week If that was the case, one would expect this to be happening more often, and easily findable. For that matter, it should have been caught and patched by now (I've been having this problem for about a week). – Iszi Oct 31 '13 at 22:18
  • So, strangest thing. I go to launch it while I'm running Process Monitor, give up on trying to make sense of the thousands of events that match every filter I think might be relevant (except none match a filter for paths including `P:`), and then when I close Process Monitor I find Google Drive is up and running behind it. I'll see if this holds up, and close this question after awhile if I don't run into the problem again. – Iszi Oct 31 '13 at 22:31
  • @HenriquedeSousa I would, if I knew what fixed it. As stated in my earlier comment, the problem mysteriously self-resolved. So, I can't definitively say whether your answer would have worked for my case or not. – Iszi Feb 15 '15 at 23:39
  • Even google ITSELF now states that the solution is to follow the instructions in my answer! And at that time that information was not even available... – Henrique de Sousa Feb 16 '15 at 18:30

The solution of @pestul didn't work here. Even with diagnostics mode (C:\Program Files\Google\Drive>googledrivesync.exe --vv), the app failed to start.

So I deleted the C:\Users\*username*\AppData\Local\Google\Drive folder and the app started again. Of course you will have to re-enter your credentials and start the whole sync process from the beginning BUT the new GoogleDrive version (1.18.7821.2489) doesn't force you to start with an empty folder, meaning you can point to the old folder AND it now detects if the local files are the same on the server, eliminating the need to synchronize everything from scratch!

As an example, it took approximately less than 5 minutes to synchronize my 13.31GB folder with 60.063 files in it. In the middle of the process it will show a popup window telling you the number of files that exist only locally, the number of files existing only on server, and the number of files conflicting.

  • 1
    The answer to delete the Google Drive folder from the user folder worked for me, except in XP it's here: C:\Documents and Settings*username*\Local Settings\Application Data\Google\Drive (I would have commented, but not high enough reputation yet.) – user2391738 Jan 20 '15 at 19:48
  • This worked for me, only it wiped my entire (at that point unsynced) existing Drive folder, so backup first and use caution! – Joram van den Boezem Jan 28 '15 at 11:40
  • There is a trail of recent comments. It looks like Google really messed something up. This worked for me too. Windows 8.1. But for some reason, it said I could not delete the directory because the file was in use! I could not find any handles with Process Explorer, so I deleted it from the command line, while told me the exact file locked. I tried to delete that in Explorer and it said Notepad++ had a lock?! I never opened that file, but I closed Notepad++ anyways and was able to delete it. Then Drive wanted to sync 600 files, because I renamed a directory locally. – Chloe Jan 29 '15 at 5:33
  • 3
    I am confirming on this answer is the correct one, I just finished Chatting with one of the Google support team, and the solution is deleting the configuration folder of the drive in the AppData folder and start the program. Now the program will require you to set it up from the beginning, and then it will compare all the filed you have on your PC with the files on the cloud, then it will sync only the change. I am confirming no mess happened, no file deleted either from the cloud or from PC. – Ahmed Hamdy Feb 15 '15 at 13:25
  • In my case, I used VoidTool's Everything to find everything related to Google Drive in AppData folder, and deleted them all. Then it worked again. – Saeed Neamati Aug 27 '15 at 8:45

I FIGURED IT OUT! At least for me that is.

See if this is the case for everyone. Windows Firewall and Advanced Security. Under the 'inbound rules', if you see a one or two block 'chrome.exe' rules. Disable both of those rules. I then ran diagnostic start again for Google Drive and it worked straight away! You may not even need diagnostic startup, it may just work.. or I hope this works for everyone.

  • Good to know that's working for you. Wish I could figure out what did it for me. Once I started looking at it with Process Monitor, it suddenly worked. It's nice that it's working, but frustrating that I'll probably never know why. – Iszi Nov 6 '13 at 16:22
  • 2
    @pestul This answer appears to be taken directly from productforums.google.com/forum/#!msg/drive/OF3WdGyBFok/…, in which case you should edit your answer to properly attribute it to that source. – Twisty Impersonator Feb 6 '15 at 18:43

protected by Community May 11 '15 at 11:39

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.