3

It appears that UAC is broken.

I can't move/delete some file/folders. When asked to use administrative right (and say yes) it shows the loading bar and then nothing gets moved/deleted. There is no error whatsoever.

I opened the control panel, user account and when I click on any option with the Shield (administrative rights) the mouse changes to loading and then goes back to normal, not opening any menus or showing any errors.

  1. Already did a sfc /scannow , no errors found
  2. Already used Microsoft's Fix it, recycle bin broken and repaired, still the same error
  3. Used microsoftaccounts tool , these are the errors I got:
    • Problem with Microsoft account policy... <- this is the problem (didn't fix)
    • Trust this PC <- loop of redirections, can't get to trust this PC (only one with w8)
    • Problems with system registration : I think it is because of the soft system reset
    • Some settings have sync turned off : I never configured anything to sync
    • Rootcauses found and created logs : I would like to know where the logs are saved...
  4. Had to use a ".reg" file to change UAC setting to never notify, thinking it would fix this, no, it stopped asking though, I can still open a cmd with Administrative rights, but can't access the UAC settings
  5. Accesed Administrator account (net user administrator /active:yes)and even with that account I could change any settings

So there it is, I don't know what else to do at the moment (this PC broke with the 8.1 update and was restored to the factory configuration. It broke several drivers and kept most of the registry entries I can't find the cause of this problem.

Other info: I tried to delete a file in a program folder and couldn't, downloaded unlocker to check first if it was permissions but no, it showed me a message telling me that there wasn't any error, and asked if I would like to delete it. I clicked on yes, and it did delete it. What amuses me is that I can't without this tool, not even using the feature that takes over ownership.

Edit: Wow, in a not crappy PC chkdsk is fast, completed with no errors found : /

EDIT2: I'm editing so anyone who sees this questions knows that I'm here, if I manage to fix this I will post the solution here

Edit 3: I used the AMD Cleanup utility and it seems to be the culprit, when I open services.msc in the description I get several errors (code 2). Can't seem to find a fix without refreshing again...

  • Did you run a chkdsk? – Ƭᴇcʜιᴇ007 Nov 2 '13 at 2:21
  • no i havent encountered any indication to be a drive problem, and the notebook is a month old, almost all this problems trace back to installing 8.1 and get driver incompatibility, the solution was a system refresh.. wich broke it, and now the only solution i have found is to refresh again... i will do a chkdsk but since it takes a long time i will wait until i cant think of any other solution – Antoros Nov 2 '13 at 2:24
  • I suggest that since your examples seem to be possibly related to disk troubles (moving directories, certain dialogs not opening). – Ƭᴇcʜιᴇ007 Nov 2 '13 at 2:31
  • added another paragraph about that, it isnt about deleting files (because i can by force) is about my permisions to do so not "triggerinig", but i will follow your advice and do a chkdks right now, maybe it wont take long – Antoros Nov 2 '13 at 2:32
2

After a long research I found a solution that is not refreshing or Formatting Windows 8.

The AMD uninstaller utility broke my PC. In a very tiny font they warned that it was only supported by windows 7. I didn't read that and it broke my UAC.

I spent days with UAC disabled by registry but that's not a very optimal solution because of security and it broke "Metro" (or whatever is called now).

Today I found the solution and the steps are as follows:

Restoring UAC

The solution is very easy to implement

1.- Open Regedit = Windows+R > regedit

2.- go to this Key =

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\MUI  

.
3.-Right Click on "MUI" and add new Key, and name it:

StringCacheSettings

.
4.- right click on the right panel right click and create a new DWORD and name it:

StringCacheGeneration

.
5.- Double click it and set the following HEXADECIMAL VALUE:

38b

.
6.- Reboot and be happy

I found the solution Here. I wrote it here as a backup if the page goes down. I hope someone finds this solution faster because of it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.