15

Evertime I open google drive I get the following error msg. I tried copying and pasting the dll file into system32 and sysWOW64. But the problem still persists. 1

  • 2
    looks like googleDrive uses pyInstaller, interestinng. – Naib Nov 2 '13 at 23:13
  • And in case anyone is wondering: Don’t even think about copying this DLL anywhere. It does not belong in the Windows folder. – Daniel B Mar 19 '16 at 19:50
13

May be a problem related to permissions (look for System Error Codes). Try the following.

  1. Open the Windows Explorer.
  2. Paste this(%UserProfile%\AppData\Local\) in address bar.
  3. Right click on folder Temp then Properties - Security tab - Advanced button.
  4. Click on button Change Permissions.
  5. Remove all permissions.
  6. Select the entry for your user name and click Edit.
    • Include inheritable permissions from this object's parent.
    • Replace all child object permissions with inheritable permissions from this object.
  7. Click OK.

enter image description here

| improve this answer | |
5

One fix is to set GoogleDriveSync.exe (generally located in : C:\Program Files\Google\Drive) in compatibility mode :

  • Right-click on the executable -> Properties -> Compatiblity -> Run this program in compatibility mode for : Windows 7 (I assume you're running Windows 8, otherwise try setting an older OS version)
| improve this answer | |
2

For windows 8 system, follow the steps bellow:

  1. Open the Windows Explorer.
  2. Paste this(%UserProfile%\AppData\Local) in address bar.
  3. Right click on folder Temp then Properties - Security tab - Advanced button.
  4. Click in Everyone, Mark Change Permission and later click Edit
  5. Mark all permissions
  6. Press Ok (continue) in all windows questions.
| improve this answer | |
1

The option Run as administrator worked for me. (I'm using windows 8.1)

| improve this answer | |
  • This worked for me. Plus, to avoid doing this every time, right click it > Properties > Compatibility > Check Run as administrator – Alaa M. Feb 3 '18 at 15:52
0

On Windows 10, going to %UserProfile%\AppData\Local\ and deleting the Temp directory entirely, and then recreating it, fixed the error and allowed Google Drive to start up and sync normally.

This is a crude solution, but it worked, unlike the accepted answer, which got permission denied, even as admin. It may need to be updated for Windows 10.

| improve this answer | |
  • Did not work ! I am running windows 10 anniversary. Only running the software as administrator works. And this is not the only application I have with issues on opening. – Nuno Aniceto Dec 2 '16 at 19:46

Not the answer you're looking for? Browse other questions tagged or ask your own question.