I am using a WD My Passport external Hard drive. The drive does not appear in Computer, Device manager nor in Disk Management. How may I bring it "back to life" or at least restore the data that was on it? I have tried two laptops, and all the usb ports of mine. Still nothing.

Note: when connected the drives lamp turns on and I hear spinning sound without the skipping sound so I guess it is still alive

The inside of the dismantled Drive are in the following pictures

Drive inside

As you can see from the two pictures the usb interface is integrated on the hard drive board. If it was possible I would remove it and insert it in another enclosure or something. But I do not know how. Please tell me how to do so, and alternatives on reviving the drive

**UPDATE 25/3/2014 I tried checking in BIOS if the drive appears but it does not. I tried changing usb ports, laptops, wires and still nothing worked. The drive sound "alive". I also tried using different versions of Windows and still it does not appear

  • i believe it's a mechanical hdd. can you feel it spin up or vibrate once plugged in? can the usb cable work on another usb device? also try if it works by slightly tilting the angle on the cable once plugged in.
    – PatricK
    Nov 4, 2013 at 5:03
  • I do hear and feel the spinning, but that's that, the rest do not happen.... Nov 4, 2013 at 13:06
  • if you can place it right next to your ear, can you hear the reading arm flicking? i have seen some hdd arm got stuck at outer edge of the disc but motor spins fine. In this case, you might have to try place it vertical, where the arms points up, then give it a few taps when it spins. another possible method is to put it in a sealed plastic bag, put in freezer for a day, take it out of freezer and let it warm for a few hours, then try connect again.
    – PatricK
    Nov 5, 2013 at 0:43
  • I used to hear flicking bout a year ago, I was going to search for an answer on how to stop it but the flicking stopped around 3-4 months ago so no more. What will the freezer option fix? Nov 6, 2013 at 14:49

4 Answers 4


First thing to do is try another USB port (if it's a desktop, switch between front/rear ports too) or another computer.

If it still doesn't show up, dismantle the drive case and remove USB interface. You'll have a bare hard drive left that you can put in a new USB drive case or connect directly to the computer with a SATA cable (and power cable too!)

  • I dismantled the drive but I do not know how to remove the usb interface as it is directly connected on the circuit board. I tried different laptops, and usb ports and still nothing Nov 3, 2013 at 13:35
  • Added photos of the dismantled drive Nov 3, 2013 at 14:17
  • I apologise for the delayed reply, I was abroad and did not bring the drive with me. I updated my question with a few more details Mar 25, 2014 at 21:31
  • I forgot to upvote your answer before so I did now Nov 6, 2014 at 8:55

Try using different USB ports. I have a WD My Passport as well. If that doesn't work then check your BIOS utility to see if it shows up there. Getting to your BIOS can be acheived by by pressing a key while the Bios loads when you start your computer. The key is different depending on manufacturer. Some have to press f2 Mine makes me hit Delete. just watch the startup it will tell you to press **** to enter setup. After those steps come back with info so I can give more info.

  • Did you even try my suggestion before you took it apart? You should always start with the other easy troubleshooting before you dismantle something.
    – jmc302005
    Nov 3, 2013 at 16:30
  • It's not difficult to put it back together, that's why I took it apart. I did so I could check if could load it into another enclosure case I had. Please add more details on what to do when I am inside BIOS Nov 4, 2013 at 13:07
  • The Bios is different per manufacturer. So I can't tell you step by step where to find it. Look for Integrated Peripherals or Devices, something along those lines. You can safely browse through the settings as long as you don't change anything. Once you find the connected drives, look to see if your Passport is listed. It may not be titled Passport. You should know how many drives you have on your box so if that many is not listed then it isn't being found by your system so it is a disk problem and not the OS. When you exit the Bios utility make sure you exit without saving changes.
    – jmc302005
    Nov 4, 2013 at 13:33
  • I will try it and let you know Nov 4, 2013 at 13:37
  • Afterthought, since you have the enclosure off. you can find its ID and look for that in Bios. I think it lists it on the enclosure as well. It would be the id that starts P/N: followed by WD(RandomNumbersAndLetters)
    – jmc302005
    Nov 4, 2013 at 13:42

I had the same problem. The reason for this was too high HDD energy consumption.

I solved this problem using a cable like this:

enter image description here

  • But the drive worked perfectly before the problem started May 29, 2014 at 16:48
  • I forgot to upvote your answer before so I did now Nov 6, 2014 at 8:56

As it turns out the hard drive was completely broken. The two reading heads were not moving at all which had to replaced in order get back my data

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.