1

I'm currently doing a spare-parts build to put a media computer in the living room, and having a devil of a time getting my Rosewill RNX-6300 wireless card to connect to my network.

I'm trying to set it up using Windows as opposed to the proprietary Rosewill software -- the Rosewill software is a little over my head. It can find the network fine, but when I try to connect, I don't get the password prompt -- it moves straight to "validating identity," scans, and then says "Windows was not able to find a certificate to log you on to the wireless network Foo."

The maddening thing is that the card was working fine a week ago, in the same box, using the same OS. I pulled everything out, swapped out the motherboard, and reinstalled Windows on a freshly wiped hard drive, and now I can't get it up and running again. Suggestions?

I've taken several runs at it, including attempting to manually change the settings for the network to include WPA-PSK and AES and the password, and I'm a bit worried that I've totally boned everything.

My router settings:

Router settings

ipconfig/all results from the XP box:

ipconfig

Again, this card was working on this network a week ago. I can't figure out why I can't get it up and running now.

There's no WPA2 on the card, just WPA and WPA-PSK:

WPA options on Rosewill card

WPA-PSK was the only setting that would let me enter a network key. I had TKIP and AES as options there, but cipher type is AES on the router, so I chose that.

(I tried TKIP later, when this didn't work, with the same results as described below.)

So I set it to WPA-PSK / AES and entered my security key. It's mixed letters and numbers, 32 characters long.

No joy. Still "waiting for reply" in the main screen, and "cannot find certificate" on the pop-up.

And if I try again and return to the settings again, it is reset to Open/AES. It also re-enables 802.1x in the Authentication tab if I've deselected it with WPA-PSK. It also reshortens the password.

Open/AES re-selected

I have no idea how I blundered into getting this working in the past. I am, as you can tell, far from proficient at this. It was working before, though. What am I getting wrong?

  • Yes -- I think that's covered in the first image up top, which is a screenshot of my router settings. It's 2.4GHz, WPA2-Personal/AES, and I'm not sure about regular or wide, but in "Mode" it says it takes 802.11n, 802.11g, and 802.11b. – JeanSibelius Nov 3 '13 at 14:04
  • Is there a popup with "Windows was unable to find a certificate to log you on to the network shepherd"? (Yellow popup like here ). Asking because certificates are used for WAP2 enterprise and not for WPA2 personal. – Hennes Nov 3 '13 at 14:14
  • Yes, that's exactly the pop-up I'm getting. – JeanSibelius Nov 3 '13 at 14:30
  • In the same link, skip to step 5. Is there a tick at "Enable IEEE 802.1x authentication for this network"? If there is, remove it. (802.1x uses a radius authentication server. This is probably not the enterprsie setup which you have at home. (Basically that uses a certificate to contact a central authentication server whereas you use a pre shared key). – Hennes Nov 3 '13 at 14:39
2

from your screen shots what I am seeing is you chose wpa2-only for your encryption on your router and you are setting your ethernet card to wpa-psk. You need to change the routers encryption to just wpa or wpa-psk. your card does not support wpa2 if i am reading your dropdown list correctly on your card.

  1. Set router to open first as well as your card.
  2. try to connect
  3. connection established then try
  4. set router and card to wpa / aes
  5. set your password (you don't need 35 characters I'm sure no one is going to try and hack onto your net lol) 8-12 characters is plenty. Mine is only 12 characters.
  6. try to connect.

You can try stepping up encryption to wpa/tkip, wpa-psk/aes, wpa-psk/tkip however the settings must be the same on both your router and your card. That said you cannot have wpa set on your card and have wpa-psk set on router.

Write back your results so I know if you got it fixed.

  • Also as a side note. for better screen shots search your start menu for snipping tool. much better than taking pics with your phone :) – jmc302005 Nov 3 '13 at 14:18
  • Absolutely right about the pics, it's just that without Internet the camera is far easier than snipping, editing, transferring to USB and carting across the house. :P What's really bugging me is that -- I swear to God -- this card was working, in a box, 7 days ago. The power supply died, and I decided to transfer the card to another system. I haven't changed my network settings since then, and the card is physically the same. – JeanSibelius Nov 3 '13 at 14:31
  • 1
    snipping tool is windows 7/8 only (maybe vista has it, I donno). He has to printscreen and paste, like a XP using savage, alas. – Journeyman Geek Nov 3 '13 at 14:43
  • There is always [start] [run] mspaint.exe to cut away unimportant parts. And ALT-PrintScreen to just capture a single window. – Hennes Nov 3 '13 at 14:46
  • Damn I missed the certificate part. However what I was having him do was getting him there lmao. – jmc302005 Nov 3 '13 at 14:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.