Avast Antivirus asked me to delete a probable virus and to restart to perform a checking.

I had to stop the checking at the middle of the procedure as I needed the computer. It was imposible to turn off the computer pushing the power button (as it entered in suspension mode, no matter how long I kept pushed the power button). I removed the battery as the only way to restart the computer.

Windows 7 said that there is a problem to iniziate Windows. Windows 7 tried to fix the problem without success. Windows 7 started after that though.

Everything is OK but the USB mouse. The USB mouse sticks and freezes each couple of seconds more or less. The tactile mouse (PS2) works well.

I googled for solutions but the posible solutions didn't work for me.

What happened? How could I fix it without formatting and reinstalling everything?

UPDATE: this is what I did:

Windows 7 checking hard drive errors tool

  • "I googled for solutions but the possible solutions didn't work for me": We can't read your browser history or mind, what did you try already? Try a different USB port? A different USB mouse? Try the suspect USB mouse on a different computer? Do you know exactly what Avast removed? Did you ever let it complete it's check? What problem do the Event Logs tell you that Windows tried to fix? Did you try a System Restore back to before the problem developed? – Ƭᴇcʜιᴇ007 Nov 3 '13 at 19:35
  • You are right @techie007. My mistake. I updated my question. I write a solution (which a don't like though but works so far). Something curious is that I had all the Avast shields stopped, but it detected that file though (which I don't remember, and I don't find in the statistics). It is like avast never detected anything. I didn't complete the analysis. Tonight I'll do it. System Restore was disabled with no restauration points. I'm looking at the event logs but I don't know how to find that! – chelder Nov 4 '13 at 15:25

The following solution worked for me:

1) Uninstall the default Windows Human Interface Device (HID) from the control panel

2) Uninstall the default Windows USB Mouse from the control panel

3) Install the following non default driver, for Microsoft mouses: Microsoft Hardware USB Mouse (my mouse is not a Microsoft mouse)

New drivers installed for the mouse

Notice that just updating the driver from the default one to the Microsoft one did NOT work for me. Actually, it worked till I restarted the computer. I had to uninstall it previously to make it works after restarting too.

I don't like this solution though as I don't know why the default drivers stopped working.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.