7

I am using Ubuntu 13.10 (with Gnome 3.10.1) and MonoDevelop 3.0.3.2.

Before switching to GDM and Gnome 3 MonoDevelop worked just fine, but after switching I get this popup: "Could not connect to debugger" (as the picture shows, first the "Waiting.." popup pops up, then the could not connect (all this happens instantly)).

I am aware you can use the internal console (Project -> Options -> General) but it does not do it for me. I want the Gnome-terminal as I'm used to.

Does anyone know a fix to this? (Yes, I've tried reinstalling (including apt-get purge and removing the settings in ~/home)

enter image description here

12

this little trick , works on my debian 8 (Cinnamon)

  1. Go to Solution Options via Project > ProjectName Options
  2. Under Run > General Section disable the Run on external Console for both Debug and Release Configuration

now it should work for you.

3
  • There is no such option.
    – Regis May
    Mar 11 '18 at 17:02
  • I don't see "General" under "Run". I only see "Configurations". Dec 6 '18 at 21:32
  • you dont see that option because this answer belongs to 2016 :)) Dec 8 '18 at 11:30
11

This is due to a recent gnome-terminal change. Recent gnome-terminal no longer accepts the --disable-factory argument.

Install the xterm package, then in a gnome-terminal session do the following:

$ unset GNOME_DESKTOP_SESSION_ID
$ monodevelop

This will cause monodevelop to use xterm as its external terminal and all should be well.

3
2
su
cd /opt/monodevelop && nano monodevelop.sh

in monodevelop.sh, write:

#!/bin/bash
unset -v GNOME_DESKTOP_SESSION_ID
cd /usr/bin && ./monodevelop-opt    #or monodevelop if exist

save the file and:

chmod +x monodevelop.sh
ln -s /opt/monodevelop/monodevelop.sh /usr/local/bin/monodevelop
cd /usr/share/applications/ && nano monodevelop-opt.desktop #or monodevelop.desktop if exist

in the file, set or modify lines: Exec= and TryExec= to:

Exec=monodevelop %F
TryExec=monodevelop

Save the file.

1
  • The variable is XDG_SESSION_ID on xfce, but unsetting it simply changed the error message to Debugger operation failed :-/ Nov 1 '18 at 12:28
1

What is happening here that Mono is trying to open mcs to execute the console program. But since the mcs is not installed in the system, it keeps giving that error message. You just need to install mcs and that's all.

Open up the terminal and type this command: sudo apt-get install mono-mcs

This will probably solve the issue.

1
  • Not true. mcs is installed on my system and it still isn't working. Nov 1 '18 at 11:56

Not the answer you're looking for? Browse other questions tagged or ask your own question.