3

I open a file that's read only. I change some stuff. When saving, Excel whines that it's read only. I uncheck the read-only attribute. However, the readable attribute does not propogate upwards to Excel itself, thus causing me somewhat of frustration.

How do I remove the local Read-only attribute in Excel?

Excel 07, Windows XP.

5

I read it differently from Kije.

When you open the file, if it is flagged as read only (attribute) Excel opens it in read only mode and that is fixed. Changing the attribute once it is already open makes no difference to Excel. Best bet would be to do a save as... give it a different file name, then close and swap the new file for the old one in explorer.

Other possibility is that this has nothing to do with attributes at all, and the document has been "marked as final". In the bottom left corner, where you see "ready" is there an icon next to it like a document with a rubber stamp being hit on it? If so, this is marked as final, as you will see when you hover on that icon. Go to Office button > Prepare > Unselect "Mark as final" Document will now be editable and saveable

  • Your reading is correct. The RO flag being unset on the file system does not propagate to Excel, and thus Excel blocks me from saving. – Paul Nathan Nov 7 '09 at 17:59
1

From your question I guess you are trying to fix this in the Windows (not Excel) Read Only attribute in the file's properties.

If that is true, then I would take a look at the security options within Excel.

In Excel 2003, you will find this under Tools / Options on the Security tab where you specify the password behavior

In Excel 2007 this has been moved to Office Button / Save As / Tools / General Options

There you might find the sheet has been saved with a password that lets you open file the file as read only without a password, but requires a password to modify it. The Open Dialog box could create the impression that you are dealing with a Read Only file.

If you do not know the password to open the file for update, the only way I can suggest to get around the problem is cut and paste the the sheets into a new workbook.

-1

I had this same issue recently. I recovered the file successfully but when I tried to do a "save as" Microsoft Excel stopped responding. I honestly just ended up leaving it open for 20 minutes and it went through with the save eventually. Hope this tidbit helps!

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.