34

The bad thing about Flash video was that it required a third-party plugin to play the content. The good thing was I could select which content to play; using the click-to-play feature in Firefox and Chrome.

But now that HTML5 video is getting popular, I see a lot of ads popping into view again. They are not only a distraction, they hog resources on my computer and make the fans spin full speed.

Is there a way to disable HTML5 audio/video content by default, and enable it only selectively?

  • 5
    @kinokijuf HTML5 is not just a buzzword— it's a collection of technologies that adhere to formal specs put out by the W3C, found here: w3.org/TR/html5 . Likewise, “HTML5 audio/video” are specific standards for encoding audio & video and presenting them in web browsers (using HTML5's <audio> and <video> tags). More information on HTML5 audio & video on Wikipedia: en.wikipedia.org/wiki/HTML5_Audio / en.wikipedia.org/wiki/HTML5_video – Slipp D. Thompson Jul 24 '15 at 20:01
  • 3
    “HTML5” is a buzzword. Please specify what you want to disable. It’s pretty clear (if you actually bothered to read the question, especially the second and last lines) what he wanted/wants to disable: HTML5 video and audio elements. – Synetech Jul 25 '15 at 1:01

10 Answers 10

15

In Firefox you can set media.autoplay.enabled to false in about:config though as of now this may not be sufficient for every case. An extension like NoScript (default settings) could be used to complement the missing functionality or even otherwise used by itself without the about:config setting. In NoScript it's also possible to extend the functionality to whitelisted sites (NoScript Options > Whitelist) via NoScript Options > Embeddings: Apply these restrictions ...

about:config Entries

| improve this answer | |
  • 1
    This works, thanks! I luckily use NoScript already. Still looking for a setting in Chrome. – HRJ Nov 8 '13 at 3:10
  • 1
    No problem :) Regarding Chrome, this thread (though not related to Chrome settings) could be helpful. – vWil Nov 8 '13 at 15:34
  • 2
    Firefox 34.0 sure autoplays HTML5 video as if Minitrue itself had ordered it to in Jan 2015 (case of: no Flash installed, NoScript installed with "Forbid Other Plugins" set to 'true' and with Firefox "about:config - media.autoplay.enabled" = false) and there is as yet no way to disable that. Oh well. Bug 659285 mentioned in the response above seems to indicate the FF developers are in some kind of quandary about how to control invocations of play(). I hope this gets solved. – David Tonhofer Jan 11 '15 at 7:35
8

For Chrome/Chromium, there is HTTP Switchboard (available in Chrome store or github). There is a column in the matrix which can be selectively be turned on or off, which turn on/off HTML5 video/audio/SVG/fonts -- for whatever hostnames you wish.

| improve this answer | |
4

In Firefox 36.0.4 open about:config and search for media.webm.enabled set this to false and the html5 videos will not play anymore. ;)

| improve this answer | |
3

For Chrome, I am satisfied with Stop HTML5 Video Autoplay. Does not prevent loading but good enough to prevent media from auto playing.

| improve this answer | |
2

https://superuser.com/a/406044/105108
This post helped me to disable ogv video. Setting media.ogg.enabled to false in about:config worked for me.

| improve this answer | |
1

According to a blogpost, to disable HTML5 and autoplay of videos in Mozilla Firefox is to force them to use Flash version.

Type about:config in the Mozilla URL field, make a new boolean with type media.html5video.blocked and give it value of true.

| improve this answer | |
1

Nothing worked for me.. tried everything but html5 still sneaked in.

Ultimately.. installed opera 28, installed extension "Disable Youtube™ HTML5 Player" and it's good now.

hope this helps.

| improve this answer | |
1

The firefox extension Flash Control always worked for me. It disables autoplay of both flash and html5 media. It provides placeholders F for flash and V for html5 media that can be clicked to get played.

| improve this answer | |
1

For Firefox, you can use the Toggle HTML5 Video extension to disable HTML5 video. Worked for me.

According to its docs, it works by changing the following about:config settings:

  • media.ffmpeg.enabled
  • media.ffvpx.enabled
  • media.ogg.enabled
  • media.mp4.enabled
  • media.apple.mp4.enabled
  • media.webm.enabled
| improve this answer | |
1

Disabling video autoplay in Firefox

As of Firefox 69, you can now configure Firefox' settings to block all or specific websites from autoplaying videos.

To always allow or disallow autoplay for all videos or media with sound:

  1. Click the menu button menu button and choose Options.
  2. Select the Privacy & Security panel.
  3. Scroll down to the Permissions section.
  4. Go to Autoplay → Settings. Default for all websites: Block audio is the default setting. Set this to Block Audio and Video to block videos too. Or set this to Allow Audio and Video and you can configure blocking autoplay on a per-site setting, instead.

Youtube.com's site permissions will look like this if set to block video autoplay. You can also opt to set the autoplay permission to allow autoplaying videos on youtube.com only and not other sites.

Youtube.com Firefox site permissions

Disabling video autoplay in Chrome

The AutoplayStopper Chrome extension can stop HTML5 (and Flash) media from autoplaying in YouTube and other sites. It will show the video preview thumbnail instead of autoplaying.

AutoplayStopper in action.

Using Flash instead of HTML5

YouTube Flash Player extension for Firefox or Chrome:

A very lightweight add-on that forces YouTube to play videos using Flash Player because it consumes less material resources (CPU, RAM) and offers more resolution choices than the HTML5 Player.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.