45

I have an external monitor connected to my laptop, and the external monitor is set as the primary display. My problem is that sometimes after I've connected the monitor, the App Switcher still shows on the laptop screen. How can I set/reset it to show on the primary display (external monitor)?

enter image description here

69

The App Switcher tends to follow where the Dock is located. Place your dock in the monitor where you want your app switcher to be displayed.

For example: if you have two monitors and the dock is on left side hiding then the app switcher will be on left monitor.

If the Dock is in bottom, the app switcher will be on the monitor where the dock is activated lately.

BTW I am on Mavericks.

  • 3
  • 5
    FYI - If you set the dock to autohide, it will follow your cursor. I.e. dock is autohid on the bottom--place your cursor on the bottom of any monitor and the dock will move to that monitor. If you do this right before cmd + tab all is well :) – James Jun 11 '14 at 20:38
  • 8
    for me, it was whatever monitor had my hidden dock most recently activated. – bearMountain Aug 25 '14 at 23:56
  • 4
    Indeed, on Yosemite, when dock is autohiding, the task switcher will be on the display that last unhid the dock. Which is pretty annoying at times. – Brendonwbrown Feb 27 '15 at 14:27
  • 1
    In my opinion, the most sensible place to show the switcher is on the display that you are looking at. And because Mac does not (yet) track your eyes, the switcher should, by default, be replicated on all displays. If presenting, you'd choose different behavior. – jarmod Feb 15 '19 at 22:50
4

In OS X Mavericks, the task switcher is now shown on the screen that previously showed the dock (and in Mavericks this is both screens).

I don't really ever use the dock, but the task switcher jumped to my second monitor (Macbook) all the time anyway.

What worked for me was to move the dock from bottom of the monitor(s) to the right of my main monitor. The task switcher has not jumped back since i did that.

  • 1
    This worked for me on Yosemite as well. It seems the application switcher is displayed on whatever display also shows the dock, which itself doesn't jump after you set the "primary" display in the system display settings. – Brian Gerstle Feb 9 '15 at 14:53
4

Just move your mouse pointer to the bottom of your primary display to cause the dock to pop-up (if hidden), and the App Switcher will pin to the display. If you activate the Dock on your secondary display, the App Switcher will pin to it. If you do not use the Pop-up Dock feature, just Click your Downloads icon on the dock in your primary display to move the App Switcher focus back to that display.

  • 1
    On Mavericks with multiple monitors, I've noticed that the App Switcher shows up on the display that your mouse last hovered over the dock. Weird... – Dan May 27 '14 at 15:12
0

I had the same exact problem and it was driving me insane, so I opened the system prefs and went to the monitor tab to see if there's a setting, I found nothing and close the preferences and then magically it got fixed, now the application switcher is on my main monitor!

  • 2
    Hello and welcome to superuser.com. Please do not use the answer fields to post comments. Wait until you have enough reputation points to post comments and do it then. Answers are for answers with a description of how to solve something. – Mogget Nov 7 '13 at 21:27
  • 1
    Hello again. Don't be sorry. This happens all the time. You can if you want delete your answer by pressing delete where is says share|edit|delete|flag. Just know that in general, the "regulars" want the answer fields to contain specific solutions and comments about something to be in the comments. You will have the required reputation points to write comments soon, so don't despair. Cheers. – Mogget Nov 7 '13 at 22:31
  • 1
    To me this seems like an answer/solution, I don't think you should remove it. Thanks, will check it out! – Znarkus Nov 8 '13 at 6:19
  • 1
    The solution is actually easier than I thought, the fact is that the app switcher is going to appear in the monitor where the dock is, I have my dock hidden, so to make the app switcher appear on the opposite monitor I just have to slide down the mouse to make the dock appear on that monitor. This way is so easy to select which monitor you want as primary on the fly. No need to open system preferences. – Nel Nov 12 '13 at 22:09
  • 1
    @Nel, If that solution works for you, you should update your answer to reflect it. – DanteTheEgregore Nov 13 '13 at 15:46
0

Drag to white bar to the primary screen (where you want the app switcher to appear) solved it for me. If it's already on the the primary screen, switch it back and forth to make it work. Screenshot

0

If you're not really using your laptop monitor when you've got your external monitor attached, you can turn on display mirroring to make it act like you've only got one monitor attached.

Go to

  • System Preferences
  • Displays
  • Arrangement
  • Check "Display Mirroring".
0

I had this same problem with Mavericks, and I am happy to say that it seems to have been dealt with in Yosemite. There is a setting that allows you to control where tab-switcher appears (e.g. monitor with mouse or monitor with active window).

  • 1
    Where is this setting in Yosemite? – xgdgsc Oct 20 '14 at 7:26
  • I think it was in preferences>dock but I can't say for sure. Either they removed it (unlikely) or it doesn't show up when you don't have an external monitor connected. It could also be in mission control. – fredcallaway Oct 21 '14 at 13:29
  • 1
    This sounds nice, but I can't find it in any of the places you have listed even with two external monitors plugged in and running. Any other thoughts? – spex Jan 5 '15 at 18:43
0

On my MacBook Pro an external monitor, I did the following to get my task switcher on the MacBook screen:

  • Go to System Preferences ➔ Dock
  • Turn off Dock Hiding by checking the checkbox for "Automatically hide and show the Dock".
  • The dock now displays on my MacBook Pro screen.
  • Now turn Dock Hiding back on by clicking the same checkbox.
  • Now my task switcher returned to the MacBook screen.
0

Latest Mavericks (10.9.5 as of 2014-09-26):

The dock shows up in both monitors for me which is how I like it. When the App Switcher occasionally appears in the wrong screen, my solution is to interact with the dock in the screen where I want App Switcher to appear.

By "interact" I mean do literally anything with it. Turn magnification on and off again, whatever -- even just clicking on it seems to work. This always seems to get its attention and tell OS X to consider that screen the current primary. Nothing in the System Preferences > Displays seemed to help, but this little trick has, for me, consistently.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.