3

I made an image of my whole drive last night now I need to restore it back. However Clonezilla complaint that the drive is too small by a crazy tiny margin:

Destination disk is too small!
Destination disk size: 976773165 sectors (500.1 GB)
Source disk size from the image: 976773168 sectors (500.1 GB)

I do not get it. This is the exact same drive. Clonezilla also verified that this backup was restorable when I imaged it.

Any recommendations or insights on how to force Clonezilla to make this restoration back?

I have been cloning with Clonezilla for couple years for backup. Now when I need it to use it the first time to restore back, it does not work.

11
  • Maybe you need to do a low-level format of the drive with some LiveCD utility? I've never heard of such a cloning issue before though. Can't wait to see the other responses – MonkeyZeus Nov 6 '13 at 19:40
  • First you must understand size different is greater then 3 bytes. A sector isn't 1-byte. I would verify you only have a single partition. Of course its entirely possible the number of valid sectors has changed by three, if thats the case, your target hdd is no longer big enough for the target data. – Ramhound Nov 6 '13 at 19:41
  • @Ramhound, I made the image last night. The image had multiple partitions, and I imaged the whole drive. How can valid sectors can change if all I did was to try to restore it? I edited the title based on your information – yarun can Nov 6 '13 at 19:45
  • @MonkeyZeus, what is a good method to do low level format? – yarun can Nov 6 '13 at 19:46
  • @yaruncan - The firmware on a hdd continiously go through and mark bad sectors. Use your favorite S.M.A.R.T tool to determine if the number of bad sectors is high. – Ramhound Nov 6 '13 at 19:48
2

I had the same issue. I found problem was in connection! When I used "DeLOCK Dockingstation SATA HDD > USB 3.0", Clonezilla showed 3 sectors smaller disk! So I used simple SATA>USB3 cable and Clonezilla showed correct disk size!

So, correct cable solved my issue.

0

I had the same issue (see here) and I think there is no solution. I always thought that X sectors = Y bytes, thus 1TB should be only one certain amount of sectors. But it turns out, each brand can (and does) manufacture the disk in different real, total size, and they can presumably sell as long as it has at least 1TB.

In my case I tried with an external USB disk 'Seagate Expansion' (1TB) as the destination disk and it was one sector too short. So I thought, "bad luck" and tried with a 1TB 'WD Elements', and now the sectors count is even more far away from the sectors of my source disk.

So the only solution (if you don't want to try all disks in the market) would be to buy exactly the same disk as the source drive. In my case the source drive is also Western Digital, but probably can't buy it nowadays, so I will have to use a 1.5TB or 2TB if I want to clone sector by sector..

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.