1

The system is Windows 8.1 Pro 64-bit, Internet Explorer 11. I reinstalled my operating system within the last week so there's very little in the way of "extras" on here that could be causing this.

The issue is that I cannot start IE unless I run it as an Administrator. Running as an admin works fine. Running it normally will just result in the IE window flashing open and then immediately closing. Looking at Task Manager, it's definitely quitting (i.e. not just getting hidden or anything).

I see nothing in the Windows logs (application or system).

I'm new to Win 8.1 and IE 11, so perhaps there's some good reason for this? Any idea what's happening?

6
  • 1
    run Process Monitor in background and capture the IE run 2 times (with admin rights and normal rihgts). Now compare the differences. Nov 7, 2013 at 4:56
  • It's probably because you reinstalled your OS without formatting the hard drive, and used NTFS originally on the drive - the folders are locked down to a user (your user) who no longer exists - the Security IDentifier or SID changes when you reinstall, for local accounts.
    – Mark Allen
    Nov 7, 2013 at 7:38
  • @mark-allen, thanks but no. The drive was clean (re-partitioned and re-formatted) on reinstall. Nov 7, 2013 at 15:02
  • @magicandre1981, I'll follow this advice tonight when I get home. Thank you. Nov 7, 2013 at 15:04
  • 1
    OK, one thing I noticed in the normal/failed run: a SHARING VIOLATION on AppData\Local\Microsoft\Internet Explorer\Recovery\Active\{SOME GUID}.dat There were no sharing violations in the admin run. Nov 8, 2013 at 2:03

3 Answers 3

1

I was also having the same issue and i was able to resolve this by doing the following -

Go to IE > Internet Options > Security > Uncheck "Enable Protected Mode"

1
  • 1
    This actually works, but why? I know that protected mode runs on top of a virtual file system instead of accessing files directly. Could it be that my user has insufficient directory permissions for the virtual filesystem? Apr 19, 2015 at 17:54
0

Try checking the "start in" and "target" information under the properties menu for IE. I've altered that information before in order to run as administrator.

The "target" field should be a simple path ending in an exe extension while the "start in" field should have system variables (such as %HOMEDRIVE%%HOMEPATH%).

0

Just to be sure - check if all folders specified in the registry under

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders

are present and accessible by the user. In my example, the

Favorites

folder was not present due to an incomplete profile migration. After restoring that folder in the correct location, IE was able to run under the normal user account again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.