16

Using Remote Desktop from a device with a hi-res screen (say, a Surface Pro) is decidedly tricky - as everything displays 1:1 scale and so looks tiny.

If the machine you are remoting into runs Server 2008 R2 or later, you can change the dpi zooming setting (see here).

But for older hosts, that doesn't work.

Using normal Remote Desktop, you can connect with a lower resolution, say 1280x768, and turn on smart-sizing. However smart-sizing can scale down (to display a huge desktop in a small area) but does not seem to scale up (to display a small desktop in a big area).

Using the Windows 8 Remote Desktop App, you can zoom - but you cannot set the default resolution of the host.

What I want is a lower resolution in the host, scaled up to fit my screen.

So both of those are close to what I want, but dont quite work. So question is:

Does the Remote Desktop App allow screen resolution to be set somehow? Is there some other Remote Desktop client that can handle zooming better?

4
  • @techie007 They gave Surface Pro as an example of a high-res screen device. Not really a duplicate.
    – AStopher
    May 29, 2014 at 15:32
  • 1
    I want to see the person who coded the maximum RDP window size limit for the smart-sizing feature. It's just a window with an image stretched to fill! Just leave the max size limits out of it and it would have done exactly what we wanted!
    – RomanSt
    Aug 6, 2014 at 1:45
  • The bottom line is that the RDP client on Win10 should have a MANUAL SETTING for host dpi... because if you are connecting to older servers, the RDP protocol does not pass dpi.... A current thread on this superuser.com/q/1030041/15466 Jan 25, 2016 at 16:06

3 Answers 3

6

I eventually found a solution to this via this blog post by Falafel Softare.

Basically:

  • Download Microsoft's souped-up RDP client called Remote Desktop Connection Manager 2.2
  • When you add a new server, go to the 'Remote Desktop Settings' tab of the Properties and select 'Same as client area'

I've written this up in a bit more detail with screenshots on my blog.

Edit: Remote Desktop Connection Manager 2.2 has been replaced by version 2.7. People in comments say 2.7 will work on Win8.1 with some settings changed, however on Windows 10 doesnt look like it solves the problem. Unfortunately MS have not left v2.2 anywhere for us.

6
  • 2
    Perfect! Just to clarify, this does not require any configuration at all; what happens is that RDPMan is not high-DPI compatible and so Windows simply bitmap-scales the whole lot. Which is all I needed to begin with.
    – RomanSt
    Aug 7, 2014 at 2:13
  • 2
    Note that in later versions of this tool Microsoft has "fixed" the lack of high-DPI support, which means codeulike's trick no longer works. Be sure to download version 2.2 specifically from the link in the answer.
    – user369080
    Apr 24, 2015 at 20:32
  • @codeulike - I just downloaded this on my Win 8.1 machine as I don't intend to go to Win 10. It says it needs .NET 2.0 - Why is that? I guess its designed for Win 7 and 8.1 gets stuck in the middle.
    – Alex S
    Aug 27, 2015 at 16:40
  • 1
    For RDCMan 2.7 microsoft.com/en-au/download/details.aspx?id=44989 make sure to click on checkboxes "scale xxx" on Server properties -> Display Settings Jan 11, 2016 at 22:41
  • I tried those steps (though cannot find 2.2 of Remote Desktop Connection Manager, and had to use 2.7, the current one). The steps do not work.... Aaaack! Working the issue here: superuser.com/q/1030041/15466 Jan 25, 2016 at 15:45
2

In Windows 8.1 and the corresponding Windows Server 2012 R2, there is a new feature (though not mentioned in the docs http://technet.microsoft.com/en-us/library/dn283323.aspx ): there is an integration with the window manager (DWM) of Windows such that the remote machine (server) will try to match the client's DPI, thus making things look natural size (bigger).

It looks a bit weird on my Surface 2 with some older programs that are not designed with scaling up in mind (basically, DWM just zooms the window, resulting in pixelated apps), but it works.

4
  • this is a frustratingly poor attempt by Microsoft to fix this issue. sure - it might work if you ALWAYS use your Surface to access a remote desktop and if you ALWAYS log out, but if you routinely switch between two different client machines without logging out like I do then this is far from being a solution. plus an awful lot of software doesn't work well with DWM zooming anyway
    – Simon
    Sep 25, 2014 at 18:58
  • I can scale DOWN on the Surface by resizing the window and it bitmap scales, but it won't let me scale beyond 100%
    – Simon
    Sep 25, 2014 at 19:04
  • @cdavid - How can I make this happen from 1080p Win 8.1 machine to Surface Pro 3 Win 8.1 client @ 2560 | QHD
    – Alex S
    Aug 27, 2015 at 16:44
  • @AlexS This behavior is the default. If you see too big / small windows, then try to log out on the remote computer and log in via MSTSC. Also, in Windows 10, the apps seem to handle different DPIs a lot better.
    – cdavid
    Aug 27, 2015 at 16:50
2

Microsoft released an app which on iOS and Android is known as RD Client, and on windows App store as Microsoft Remote Desktop.

This app will natively try to connect with a lower resolution to make the experience more viable. But what it also does is allowing you to set the desktop resolution itself, and by pinching the screen, you can then zoom in, so you only see a portion of the screen if you need to read, or pinch out if you want to see the whole desktop.

I have a 2560x1440 27" monitor that I use to connect to my RD server, and my mobile phone with 5.6" has the same resolution. I can connect to the same desktop, but unlike with my desktop, from my phone, its just not readable. But the pinch and zoom makes it perfect to work with, a solution you seem to be after too.

I do not have a Surface pro, so it may be that the setting is located differently than on my Android, but I'll tell you where I found it on my android so you can look for it on your device.

It can either be specified for a specific pc/server, or globally for all connections.

Go to the menu of the app itself and you'll find Display Resolution. Press + Custom and add your own resolution, set it to 100% scaling. There is a "Match this device" option, but that will induce scaling, and we don't want that.

Once added, select that resolution, and connect. Now you should have what you want, and you can zoom in by pinching.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.