5

When creating a CSV file from an XLSX workbook with the new Excel for Windows 8, I get a file filled with semicolons instead of colons.

How can I change that? I even had to reopen the file with Wordpad to find out why my file could not be exported to a data management program.

  • 2
    What's the new excel? 2013? – Raystafarian Nov 8 '13 at 0:06
8

Your Windows regional settings are set to use semi-colons instead of commas as the list seperator symbol. You'll have to re-configure those in order to force Excel to use colons instead of semi-colons.

Check out this page to find out how to do that: http://www.rawcomputing.co.uk/windows8/windows-8-tip12.html The list seperator symbol should be configurable on the window that pops up when clicking the "Additional settings..." button on the "Region" window.

  • Note, that in newer Excel versions you can change the list separator right from within your Excel options – nixda Nov 7 '13 at 22:05
  • 1
    Oh? I'm using Excel 2013 and just scrolled through the options without finding any option. Where exactly can you configure the list separator symbol in my version? – Hauke P. Nov 8 '13 at 9:30
  • Sorry, I may have confused thousands separator with list separator – nixda Nov 8 '13 at 10:24
  • Okay, yes. I found that option as well. What I didn't find was an option for list seperators though. – Hauke P. Nov 8 '13 at 15:43
  • 1
    This change will also affect Opening of CSV files in Excel and possibly more windows programs. If you want to make more compatible CSV file, put sep=, on top of the CSV file, then once you save the file, you can change List Separator back to whatever it was. – papo Dec 30 '15 at 3:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.