4

I've got a problem with some of my folders on this PC. At one point I had two folders with exactly the same name too. When I try to delete them I get some odd errors like:

Could not find this item. This item is no longer located in C:/path. Verify the items location and try again.

What is causing this and how do I fix it?

1
  • I have exactly the same issue. It's on an external USB drive on a network. I have several files with zero length and no extension, and they appear to have the same name as some folders I had. I can delete them without error (in Windows Explorer or using DeleteFile(), which returns success). But when I refresh the directory, there they are again. It's unfortunate you received no assistance on this. Commented Mar 10, 2017 at 20:00

4 Answers 4

2

What I have found is Windows 7 will not refresh the view correctly or frequently enough. I've gotten the same error before, but mostly on network folders. Now when I delete something, if I still see the folder or item, I will refresh the view by pressing F5.

Some have said resetting the folder views will resolve this;

  1. Open Explorer
  2. Click Organize
  3. Choose Folder and search options
  4. Select the View tab
  5. Click Reset Folders at the top.
5
  • That button is light grey, it won't work. Why is it doing that?
    – jayftw
    Commented Nov 8, 2013 at 17:19
  • Do you have full administrative privileges on this PC?
    – CharlieRB
    Commented Nov 8, 2013 at 17:56
  • Yes, yes I do. I don't know whats wrong.
    – jayftw
    Commented Nov 9, 2013 at 23:37
  • You could use the System File Checker tool to repair missing or corrupted system files. Or try a repair install of Windows.
    – CharlieRB
    Commented Nov 11, 2013 at 1:30
  • 1
    For anyone else with this problem: I had to reinstall Windows 7 in order to fix this issue. I saved my files and data but the OS was not recoverable in the state that it was in. This was some time ago; and it may also have been the result of a bad hard drive.
    – jayftw
    Commented May 19, 2015 at 21:35
0

Delete these folders using Linux

Consider this: C:/path

Notice the incorrect slash than what Windows uses. Windows cannot delete these folders because the deleting program simply cannot find them when you ask it to delete them. These were probably created by Linux in the first place (this is not necessary).

Simply pop in a Live DVD and you should be able to get rid of these.

-1

It can be deleted via command prompt.

  • Open cmd with administrator privileges.
  • navigate to the location via cd command.
  • List directories with dir command.
  • Find the object to delete and issue del command.

Visual guide at youtube.

1
  • I tried this but received a message saying that the directory could not be found when deleting the folder.
    – jayftw
    Commented Nov 8, 2013 at 17:19
-1

I've noticed this on-and-off on my work PC and I just figured it out:

If I delete a file from a folder it goes away immediately, but if I delete a file from a library that contains the folder, it remains visible. And I'll get the "This item is no longer located in..." error if I try to delete it again.

For example: Deleting a file from C:\Users\username\Documents works like you'd expect, but deleting the same file from Libraries\Documents will not.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .