1

My application requires Word to be installed, so it checks the registry key

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\App Paths\Winword.exe

On one PC, this registry key is missing even though Word is installed and runs fine. We've tried uninstalling and reinstalling Word and the key is still not there. On other seemingly-identical PCs it's there. The same applies to all the office apps.

The PC is Windows server 2008 SP2 64 bit running 32 bit office 2010. The key does correctly appear under:

HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\App Paths\Winword.exe

but on other servers it's in both places

Any ideas as to what could cause this?

  • What version of Word are we talking about exactly? What version of Windows? Are we talking about 32-bit or 64-bit version of Office. More specific information the better. Udpate your question to get the downvote removed. I highly suspect the problem is the code. Most people forget that the 32-bit registry keys are accessed in a different way then 64-bit registry keys and that a 32-bit application like Word would be located in the 32-bit location not the 64-bit location unless the 64-bit version of Office was installed. – Ramhound Nov 8 '13 at 13:37
  • If you just want to make things work, add MS Office dir to PATH variable and you would be able to use winword in 'Run' if thats what you want.. – tumchaaditya Nov 8 '13 at 17:59
  • Actually start/run winword works ok - presumably Windows checks both the 32 and 64 bit AppPaths registry keys. The problem is that my program is trying to check whether word is installed and this check fails in this case – Andy Nov 8 '13 at 22:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.