I cannot get WMP 12 to import my library. I have searched around various forums and tried all the common solutions like disabling Media Sharing, deleted my %LOCALAPPDATA%\Microsoft\Media Player directory and tried reimporting, etc. but nothing works. I have even removed the Media features from Windows setup and re-added them.

I have a large mp3 collection shared on the network from another Windows box. I add the folder (tried as a mapped drive and UNC path) and it begins importing. After about 30 minutes into the import (the CurrentDatabase_372.wmdb hits just under 400MB) my WMP player stops importing and all of the icons in WMP turn to red x's and my library is gone. I close and reopen WMP 12 and the library is empty and the CurrentDatabase_372.wmdb is small and it strarts importing again. Rinse, lather, repeat. I am going nuts as WMP11 on Vista handles this same setup perfectly. I am at my wits end on what else to try.

I am running a legit Windows 7 Ultimate X64 RTM install.

Here is a screenshot of what WMP12 looks like when the import dies:

enter image description here

Any other ideas?

Edit: OK, I Just confirmed this is definitely a problem not specific to my computer or configuration. I just did a clean installation of Windows 7 Ultimate x86 on an old test machine, opened WMP12 and added the same network folder of mp3's and it crashed about an hour into the import with the same appearance as the screenshot I posted above and the library disappears.

So the problem has to be one of several things:

  1. The large size of the library
  2. The fact that the library is on the network
  3. A specific file or file is causing it the player to crash

just tryied myself. basically I wanted to save my library from external HD created with XP, and import in MP12 on Win7. No way to import it! So I opened the library with text pad, and it shows up as text file. The I have created a dummy playlist with MP12 (I called it "test") and open it with note pad as well. So, it is done! You just have to copy your original playlist (in my case the one created with XP) into the new one created by MP12.

For me, I had to cheange the header and everything went fine:

With MP11 in XP my header was:

<?wpl version="1.0"?>
        <meta name="Generator" content="Microsoft Windows Media Player -- 11.0.5721.5268"/>

That I had to change into:

        <meta name="Generator" content="Microsoft Windows Media Player -- 12.0.7600.16385"/>

and copied the rest of the file location and titles.

  • @beibo: Do you need to retype the header and what you changed it into? – Steve Jan 17 '11 at 4:35

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.