0

I recently bought a Kingston 120GB SSD and installed Windows 7 Ultimate 32-bit on it. I also have a secondary 500GB HDD: Western Digital WD5000AADS.

When I try to boot, it freezes and shows the following message:

Windows failed to start. \Boot\BCD Error code: 0xc000000f An error ocurred while attempting to read the boot configuration data.

I've tried most of the solutions I could find:

  1. Using the /fixmbr and /fixboot commands.
  2. Using /bcdboot D:\Windows.

I can boot normally if I insert the Windows Installation disc, select to boot from it and skip the button press.

The SSD is C: and the HD is F:. However, on the Repair System menu, the Local Disk (SSD) appears as D: and the HD as C:.

Also, there was a SSD partition named D:, which was active, but I deallocated it and set C: as active, because there was a missing bootmgr problem previously.

Computer Management screenshot: enter image description here

UPDATE: I disconnected the HDD and ran the Repair System again. It automatically detected the error and repaired the boot data. I reconnected the HDD after that and now everything is fine. Thanks.

  • A picture of the partition information would tell a thousand words – Ramhound Nov 8 '13 at 17:45
  • 1
    Did this installation of Windows ever work properly? What happens when you disconnect the Western Digital drive? – CharlieRB Nov 8 '13 at 18:05
  • As a note, it looks like you clobbered the boot partition - Win7 and newer require the 100 MB that you "deallocated" for booting. – ernie Nov 8 '13 at 22:33
0

Sounds like your HDD is in the boot order before the SSD.

In your BIOS ensure that the SSD is ahead of the optical drive and the HDD, in the boot order.

If the item in the boot order list is "Hard drive" or something generic like that, look for a separate (Hard) Drive order section and ensure the SSD is ahead of the HDD in there as well.

Also, you may want to disconnect the HDD from the system completely, boot from your Windows install disk, and do a repair.

Once that's done and you can boot into Windows, stick the HDD back in.

  • The SSD is ahead of both the optical drive and the HDD. I'll try disconnecting the HDD and see what happens. – Ikuzen Nov 8 '13 at 18:32
2

Looks like your boot partition is not marked as "Active" See if these steps work:

  1. Boot into GParted live CD.
  2. Locate the correct disk and partition. You wont see C:/F: and and all here. So, go by disk and partition sizes.
  3. Locate your boot partition(Usually the first partition on disk where your windows installation resides. Not necessarily the one which has windows files). Mark the partition as active and boot.
  4. Reboot and see if it works.
  5. Also post a screenshot from GParted if it does not work.

And as with all disk related stuff, do anything at your own risk(Although I dont see any risk here).

UPDATE
Disconnect WD drive. Boot to windows using windows disk. Re-write the boot configuration using say EasyBCD Free version or BCDEdit. See if this works.

  • It is active I see....disconnect WD drive and tell me what happens – tumchaaditya Nov 8 '13 at 18:10
  • I disconnected the HDD. The error still shows up, but I'll try to repair again without the WD drive. Should I use the same commands I tried the first time? – Ikuzen Nov 8 '13 at 18:44
  • I recommend using EasyBCD simply for the GUI(Or any other BCD editor with GUI) – tumchaaditya Nov 8 '13 at 18:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.