1

I'm having problems with my font on many websites including StackOverflow.

I am using Google chrome and it is all over my web browsers, I tried reseting my Google Chrome settings then re-installing my browser in the end I haven't found a single solution towards the subject, hence why I am asking for help. (I have also tried deleting the custom font, and changing my internet options.(it didn't work.)

Operating system is: Windows 7

Google Chrome ver is 30.0.1599.101.

I have some proof on the subject.

1 is what it is currently is, 2 is what it should be:

1:

#1

2:

#2

http://imgur.com/a/Gi8yy

5
  • 1
    Can you post a screenshot? – daxlerod Nov 8 '13 at 17:13
  • Yeah sure i'll edit it in. – Harkey Nov 8 '13 at 17:18
  • You say "across many browsers", yet you only mention Chrome. What other browsers did you try? Have you ensured that your existing Windows Fonts have not been corrupted, deleted or replaced? Regarding that: check out How can I restore the original Windows 7 fonts from its DVD? – Ƭᴇcʜιᴇ007 Nov 8 '13 at 18:06
  • Also, can you expand on "tried deleting the custom font"? Tried deleting what font, and how? – Ƭᴇcʜιᴇ007 Nov 8 '13 at 18:54
  • Alright, i deleted the font i change it to but that didn't help its also across IE and mozilla aswell my fonts arent corrupted they are fine as they work across word and other sites that arent using that evil font – Harkey Nov 8 '13 at 18:56
2

This is a widespread problem, especially with Helvetica Neue fonts.

Here's what worked for me to fix Helvetica Neue and Helvetica Neue Bold in Firefox and Chrome. The first line fixes the plain font and the second line fixes the bold.

To Fix Helvetica Neue in Chrome: Browse to

%AppData%\Local\Google\Chrome\User Data\Default\User StyleSheets\Custom.css

Edit the custom.css file to add these two lines:

@font-face { font-family: 'helvetica neue'; src: local('Arial'); }
@font-face { font-family: 'helvetica neue'; font-weight:bold; src: local('Arial'); }

You should see the changes immediately as soon as you save the custom.css file.

To fix Helvetica Neue in Firefox: Browse to

 %AppData%\Roaming\Mozilla\Firefox\Profiles\xxxxxxxx.default\chrome

In this folder, edit userContent.css (or create it in notepad if it doesn't exist) and add these two lines:

@font-face { font-family: 'helvetica neue'; src: local('Arial'); }
@font-face { font-family: 'helvetica neue'; font-weight:bold; src: local('Arial'); }

You will need to close firefox and reopen it to see the change.

-1

I fixed it by deleting all my added fonts.

I used Font Expert to delete the fonts.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.