(Parallels Desktop 9, latest version)

As per instructions, I switch to root:

$ su - root
$ whoami
$ echo $EUID

and then execute the installer:

$ cd /media/cdrom0
$ ./install

and I get this error:

sudo: unable to execute ./install: Permission denied

What? I'm root! What's with this? I double check to make sure the execute bit is set:

$ ls -lA | grep install$
-r-xr-xr-x 1 root root  17284 Oct 25 09:22 install

Yep. People online are saying that you need to drag the install script to the terminal after typing sudo. So I do that, and this command is what's formed:

$ sudo '/media/cdrom0/install'
sudo: unable to execute /media/cdrom0/install: Permission denied

What's the solution here?

  • 1
    What does file /media/cdrom0/install say?
    – mpy
    Nov 9, 2013 at 15:19
  • /media/cdrom0/install: ERROR: cannot read '/media/cdrom0/install' (Input/output error) Weird, because before, I had run cat install and it worked fine. Now it fails even after a reboot...
    – jstm88
    Nov 9, 2013 at 15:44
  • 2
    Try to copy the whole content of the CD to your HDD: e.g. with cp -r /media/cdrom0 /tmp
    – mpy
    Nov 9, 2013 at 16:13

4 Answers 4


So I found the solution... this crazy command (well, not so crazy, but obscure).

$ mount -t iso9660 -o exec /dev/cdrom /media/cdrom

Turns out when Debian mounts a CD (virtual CD included of course) it mounts it as non-executable. So manually remounting it specifying exec privileges allowed me to install the tools. It's weird that the non-exec mount prevented me from even reading the files (I tried copying them and got similar errors) but eh, whatever works.


The reason for this is that Parallels mounts the image with "nosuid" option.

Start a terminal, su to root and unmount the image. Remount the image. Start the installer

$ su
$ umount /media/cdrom
$ mount /dev/sr0 /media/cdrom
$ cd /media/cdrom
$ sh installer
  • maybe the script name got changed but it is install right now so do sh install instead of sh installer
    – sk2andy
    Aug 21, 2020 at 9:55

10.13.2014: This was extremely helpful!

I've tried the steps noted on Parallels:

The key, for me, was to: • unmount the CD via Parallels: Devices / CD/DVD 1 / Disconnect • remount the CD via Parallels: Devices / CD/DVD 1 / Connect Image... - Search for the prl-tools-lin.iso in: Macintosh HD / Applications / Parallels Desktop / Contents / Resources / Tools / prl-tools-lin.iso • While in Debian, load the Terminal if you haven't done so already • Navigate to the CD as noted above:

$ cd /media/cdrom0

• To make sure things are in order, lets type list to see what's inside the cd (confirming, basically):

$ ls

This should list "install installer install-gui kmods tools version". If you don't see this, you'll have to try and remount the disk. I'd suggest doing the first couple of steps via Parallels. If it works as it should, let's go ahead and copy the files to your home directory:

$ sudo cp -r /media/cdrom0 /home/***<USERNAME>***/Downloads/

I did the Downloads folder instead of tmp folder as noted above because I could not get into the tmp folder even as root. Downloads at least lets me go in, delete and confirm all via the gui if I get lazy.

• Once done, let's confirm that the cp took place:

$ cd /home/***<USERNAME>***/Downloads/cdrom0/
$ ls

• You should be able to see the following if it worked out:

install installer install-gui kmods tools version

If everything is still going according to what I've noted above, then let's go ahead and install Parallels Tools: No need to get out of the folder you're in. Therefore, if you've been doing most of what I've noted, you should be in the Downloads folder or the folder which you copied the files to. Let's run the installer:

$ sudo ./install

It will ask you for your password due sudo; let's go ahead and do so. If all went well, you should see your terminal turning into a greyish/blue sceen w. Parallels Tools Installer (tried to upload an image but I'm still new here - sorry)

Hope this helps. I know I've read several sites and spent different parts of my weekend trying to get this running.

  • So, does this actually resolve the issue (answer the question)?
    – CharlieRB
    Oct 13, 2014 at 15:44
  • It did for me. Now I can go from Debian to MacOSX 10.10 or 10.9 without any issues so far. Oct 14, 2014 at 2:44

To make your disk or image executable you have to edit the /etc/fstab file. Normally in the last line you will find something like udf,iso9660 user,noauto. Remove the noautoand insert instead exec. Remount your disk or image and now you can execute the commands from a terminal window.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.