4

This question is not a duplicate of this one:

Can I always exclude specific recipient from Reply All?

Or these which are about Outlook 2010 and are actually different issues:

reply-to-all includes my name in the TO line
Stop sending mail to myself when choosing Reply All in Outlook

Onto the Question

When I reply to all in Outlook 2007, it adds my name to the recipient list, so I end up getting the email. It has always done this with every installation I've ever had on every computer I've ever installed it on. Outlook 2010, on the other hand, has never done this. I am thinking that maybe they "fixed" this in Outlook 2010, but part of me also hopes that there's some way to keep this from happening in Outlook 2007. Essentially, I don't want the email address of the account I am using to reply to all to show in the recipient list.

2

"...sometimes Outlook sends an email to yourself when you hit the 'Reply All' button. This VBA example checks the list of recipients before sending, and it removes certain addresses from it.

http://www.vboffice.net/sample.html?mnu=2&smp=81&cmd=showitem&lang=en

Private Sub RemoveRecipients(Item As Outlook.MailItem)
Dim RemoveThis As VBA.Collection
Dim Recipients As Outlook.Recipients
Dim R As Outlook.Recipient
Dim i&, y&
Set RemoveThis = New VBA.Collection

' here add addresses
RemoveThis.Add "abc@domain.de"
RemoveThis.Add "test@domain.com"

Set Recipients = Item.Recipients
For i = Recipients.Count To 1 Step -1
    Set R = Recipients.Item(i)

    For y = 1 To RemoveThis.Count
        If LCase$(R.Address) = LCase$(RemoveThis(y)) Then
            Recipients.Remove i
            Exit For
        End If
    Next
Next
End Sub

Private Sub Application_ItemSend(ByVal Item As Object, Cancel As Boolean)
On Error Resume Next
RemoveRecipients Item
End Sub

If you are unfamiliar with VBA see here http://www.slipstick.com/developer/how-to-use-outlooks-vba-editor/ Or How do I add VBA in MS Office?

1

I believe there is no way to automate this. You will have to remove your name each time.

  • This is so true if we're not talking about third-party solutions. – thims Nov 12 '13 at 11:06
1

One reason for this happening is that your email address in Account settings is different from the one you reply with.

For more information when this can be happening, see the following articles, also detailing procedures for avoiding it:

If you cannot find your answer above, the free utility TuneReplyAll could help, where you may specify Outlook's behavior:

TuneReplyAll settings

0

A couple of users here: https://answers.microsoft.com/en-us/msoffice/forum/msoffice_outlook-mso_other/reply-to-all-includes-me/a227f787-594c-495b-8290-4105c453eaaa?auth=1 experienced the same issue, where they had added their own e-mail address as a contact in Outlook, which was the cause for them.
Once they removed themselves from their individual contact book it stopped happening.

  • If the link dies this answer becomes meaningless. It's best to copy the relevant part and add a link to the website – Dave Dec 15 '17 at 5:44
0

Because Office 2007 is no longer supported by Microsoft and therefore not receiving security patches of any sort, it's not inappropriate to suggest upgrading to a modern, secure version of Outlook.

Not only will such an upgrade solve the irritating problem that has prompted this question, it will also solve the much more dangerous issue of running insecure software that comes into contact with untrusted content delivered straight from the Internet, otherwise known as e-mail.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.