16

I'm running Win 8.1 on an OS X system via VMware Fusion. I frequently get the "helpful" tips to swipe from here or there to do this or that, which of course I can't do. In addition, many sites force IE into mobile modes because it is delivering the wrong user agent.

I saw this post regarding the EdgeUI tips issue, but I'm wondering if that really isn't just a workaround to actually fixing the problem. Do you desktop users of 8.1 (non-virtualized) honestly get those messages?

I know about user agent spoofing, but I really want to correct the native user agent string, and again, I'm thinking this is all a deeper-level fix than workarounds. Maybe not.

23

I had the same problem and noticed that in the device manager, Windows believed I had a "HID-compliant touch screen". I just told Windows to disable it and the swipe tips immediately disappeared.

Control Panel>Device Manager>Human Interface Devices>HID-compliant touch screen, right-click, select "Disable".

  • This worked for me as well. It's worth noting that you cannot just delete the device or it will be re-created; you must disable it and leave it there. Thanks Brian! – Tohuw Jan 30 '14 at 12:43
4

On Fusion, I was also able to disable the touchscreen by opening the .vmx file of the vm and changed the touchscreen.vusb.present like this:

touchscreen.vusb.present = "FALSE"

After a reboot of the VM, the "HID-compliant touch screen" device was gone.

Credit to this page.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.