13

I am connecting remotely to a computer on LAN and it keeps giving me a pitch black desktop background (wallpaper). In the RDC (Remote Desktop Connection) program on the local computer I have the option "Desktop background" enabled.

But I still can't see the background of the remote computer. Why not?

The local is running Vista and the remote is running Windows 8.1 Pro.

  • I have this too, this defect still has not been fixed, even in Windows 10. There does not seem to be any way to set a background colour behind an image that will not be displayed on an RDP client. This is something that XP still has though? – mckenzm Oct 10 '18 at 21:08
14

Check the group policy settings on the remote computer (the computer you're connecting to)! There's a remote session policy that controls whether or not the desktop background (wallpaper) is displayed when a client connects to the host. The name of this policy is "Enforce Removal of Remote Desktop Wallpaper".

a

  1. Press Win+R
  2. Type gpedit.msc and press Enter. Click Yes if you get a prompt to allow the program.
  3. Navigate to Local Computer Policy, Computer Configuration, Administrative Templates, Windows Components, Remote Desktop Services, Remote Desktop Session Host, Remote Session Environment.
  4. Right click on "Enforce Removal of Remote Desktop Wallpaper" and then click Edit.
  5. Change the setting to Disabled, or Not Configured.
  6. Click Apply and then OK. Now close the (Local Group Policy Editor) window. Done!

You should now be able to see and change the desktop background on the remote computer, from the local computer. But you will still have to enable the option "Desktop background" in the RDP (remote desktop protocol) client (i.e. RDC on XP/Vista/7/8) when you connect to the remote. Only this time, the remote computer will not be preventing you to see and change the desktop background.

To connect with desktop background enabled in RDC on XP/Vista/7/8 do the following.

  1. Press Win+R
  2. Type mstsc.exe and press Enter.
  3. Click on Options.
  4. Click on Experience tab and check the option Desktop background.
  5. Click on General tab.
  6. Provide your computer name or IP, your credentials and click on Connect.

b c

This option is ignored by the remote computer if it has the "Enforce Removal of Remote Desktop Wallpaper" policy set to Enabled. Therefore, you have to check that first before you try enabling this option in the RDC.

Note! This policy might be also found in Local Computer Policy, Computer Configuration, Administrative Templates, Windows Components, Terminal Services on some versions of Windows.

protected by Community May 25 '17 at 19:56

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.