I have a triple boot system on a single SSD: OSX, Windows 7, and Ubuntu. I use Chimera (basically another version of Chameleon) as my bootloader. Usually I can boot all 3 OSs without any issue, but after using GParted to make my Ubuntu partition 2 Gigs larger, Windows 7 throws me an error when trying to boot to it from either Chimera or GRUB.

The error is consistently: `0xc000000e can't find \Boot\BCD" (slightly paraphrased).

However, I can still get into Windows by selecting Windows Boot Manager from the boot options in my BIOS.

I've already tried several known fixes for similar issues, including bootrec /rebuildbcd (and variations), and BootRec.exe/fixMBR + BootRec.exe/fixBoot. I've also tried Chkdsk.

At best this has made it so Windows 7 boots on its own by default (making me have to reinstall Chimera and change back my boot settings in the BIOS). At worst this made it so Windows won't boot period. Now I'm back full circle where I started.

A detail that might be useful is that bootrec /rebuildbcd says that the number of found Windows installations is 0.

I'm fairly certain that I don't have a hybrid MBR. Mainly because I have a UEFI BIOS, and with that, it appears each OS can support a GPT. So it would kind of pointless to have and deal with. I may be wrong though, I couldn't find any way of finding out for sure online. However, I know for sure that the version of Windows I have installed is the UEFI version, as well as every partition tool I've used to look at my boot drive tells me it's GPT.

How do I get it back so I can boot Windows 7 through another bootloader so I don't have to manually select it in the BIOS? Preferably without a reinstall.


Alright, after some more research and some testing, I have determined that I did indeed have a Hybrid MBR that I broke (probably during the repartitioning). The reason I was able to boot into Windows from UEFI was (I think) because Windows auto repair saw that I was UFFI and "fixed" the EFI bootloader instead? I don't know, that's the most logical thing I can think of.

The reason Chimera couldn't boot into it was because Chimera can not boot into UEFI Windows, and the reason GRUB couldn't boot into it was (I believe) because GRUB was the legacy BIOS version.

So from that I gather, the easiest solutions are: 1. leaving everything as it is and just deal with it. 2. Change to a bootloader that can handle UEFI Windows, such as Clover. 3. Find a utility to fix my hybrid MBR and/or reinstall Windows.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.